netkas.org forum
August 24, 2019, 12:03:10 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: working Powercolor eyefinity 5 5x mini displayports!  (Read 36600 times)
calvintml
Full Member
***
Offline Offline

Posts: 131


« Reply #15 on: August 14, 2011, 11:38:50 PM »

Kompis, Robocop2 or dangh5, would any or all of you do me the favor of posting your cards' bioses.  I am having some issues with with mdp to vga adapters and I am curious if a bios update will solve the problem since my card is pretty old and so is the bios version.

ioreg -l -w0 | grep bin_image > binimage.txt

would do the trick.  and then just post binimage.txt

Or if anyone else knows where to get an updated eyefinity 5 bios, let me know.  Thanks.

« Last Edit: August 14, 2011, 11:43:36 PM by calvintml » Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 835



« Reply #16 on: August 15, 2011, 01:02:55 AM »

be carefull, if ur 5xxx card has MCuC section, then dump taked via ioreg wont have MCuC (cuz limited to 65kb in ioreg) and then u will break ur card if flash such image.
Logged
calvintml
Full Member
***
Offline Offline

Posts: 131


« Reply #17 on: August 15, 2011, 01:10:37 AM »

thx netkas.  so if someone can extract the whole bios using atiflash that would be best.
Logged
claudioazevedo
Newbie

Offline Offline

Posts: 3


« Reply #18 on: May 11, 2012, 05:00:35 PM »

http://www.mediafire.com/?4hy737drf09mt35

replace /System/Library/Extensions/ATIFramebuffer.kext/Contents/MacOS/ATIFramebuffer with the file from above (make sure to rename it to ATIFramebuffer).  repair permissions, clear kext cache, then inject AtiConfig=Zonalis or AtiConfig=Nomascus

either should work.  let me know

I'm VERY sorry for this, but i have the same problem. Have installed Lion (10.7.2) with a 9600GT and changed the card to an PowerColor 5x MiniDisplayPort (Eyenfinity edition?), but had a black screen at login, also a black screen if try to install again.

You posted that link on MediaFire, but is not avaliable now (deleted i think). I would like to try this kext (or what is it), because i tried A LOT of kext, lines, boot with flags with no luck.

You can post the link again?

Sorry, but my english is THAT bad... Smiley
Logged
calvintml
Full Member
***
Offline Offline

Posts: 131


« Reply #19 on: May 26, 2012, 02:02:12 PM »

This kext would not be compatible with your current osx version. Just use the latest version of lion, disable graphics injection (turn graphicsenabler off) and then it should work.
Logged
Robocop2
Newbie

Offline Offline

Posts: 4


« Reply #20 on: May 26, 2012, 03:40:31 PM »

Claudioazevedo... use original Lion kexts and parse "GraphicsEnabler=No" at boot time in Chameleon.

Calvintml, I also have the powercolor eyefinity 5 and, in Lion, this method only works for passive adapter (miniDP to DVI). I have active adapters (miniDP to DVI) and has similar problems to what happened with vanilla kexts 10.6.x:

My system: 1-active miniDP to DVI adapter (let's call this cable chain "monitor A") plugged to port 1
                 2-passive miniDP to DVI adapter (let's call this chain "monitor B") plugged to port 2.
                 3-passive miniDP to HDMI (let's call this chain "monitor C") plugged sometimes elsewhere.

In 10.6.7 era, the only combination that worked (without applying your perfect solutions) was monitor B plugged to port 2, monitor A plugged to port 3 and monitor C plugged to port 4 or 5. Depending the ports plugged, System profiler detected them wrong or right.

With your modified 10.6.7 kexts and using Zonalis, everything could be plugged wherever you want perfectly (even miniDP-HDMI audio worked!!)

Now, in Lion 10.7.4 same strange combinations of ports came alive: monitor A to port 1, monitor B to port 2= both black screen; monitor B to port 1, monitor A to port 2= monitor B OK and monitor A black (but detected). If I change black screens to other port (hot-plug without powering off), they come alive... strange since All ports are detected in System Profiler!

I guess it is related to signaling and so on you tell in firsts posts of this topic. I want to modify those (00 04 00 ...). Looked into ATI5000 kext binarys and found a lot of those hex strings, but I don't know which one is assigned to which framebuffer. am I missing some specific utility to do this?

I even don't know which framebuffer 10.7.4 system is choosing with graphicsenabler=no. I looked for it in IOregistryExplorer everywhere but can't find any "Zonalis", "hoolock" or so.

I guess you have same graphic card than me. Had you modified ATI5000 kexts? had you any of this problems?

I have this material to try everything you want:
-2 active miniDP to DVI adapters
-2 passive miniDP to DVI adapters
-1 passive miniDP to HDMI (it has checked capability to pass audio)
-1 passive miniDP to VGA
-4 monitors (2 of them DVI/VGA; 1 VGA; 1HDMI).

Thank you for your time.
Logged
claudioazevedo
Newbie

Offline Offline

Posts: 3


« Reply #21 on: May 26, 2012, 06:58:11 PM »

Robocop2, i think that i already thy this, but i will try again. BTW my adapter is a miniDP to VGA (is pasive, right?).
Logged
calvintml
Full Member
***
Offline Offline

Posts: 131


« Reply #22 on: May 27, 2012, 01:20:59 AM »

Robocop2,
I am running 10.7.4 and the powercolor eyefinity 5 works well without injection. I can use passive adapters and a displayport monitor. It also works if I inject Zonalis with edited port mappings. Here is a link to the edited ATI5000Controller.

http://gups.in/av2h

The only thing i can think of is that for some reason, apple drivers aren't extracting the port mappings correctly from your bios (which is what happens when you don't inject). So try Zonalis with this ATI5000Controller. good luck.


Also will you both extract your bios using atiflash and post it here. I want to test something.
« Last Edit: May 27, 2012, 01:24:18 AM by calvintml » Logged
Robocop2
Newbie

Offline Offline

Posts: 4


« Reply #23 on: May 28, 2012, 10:52:04 AM »

Thank you, Clavintml, I'll try your binary later.

Here is my card's bios (extracted with AtiWinFlash 2.0.1.18) http://gups.in/azby

I work with Windows 7x64 so BIOS flashers/readers are a headache. The result is 128kB only. Should I make a DOS bootable media and extract it with DOS-Atiflash?

And to Claudioazevedo:
No deberías tener problemas con un miniDP-VGA. Ten cuidado de poner "GraphicsEnabler=No" respetando exactamente esas mayúsculas porque si no Chameleon ignora el valor. Lo mismo dentro del .plist del chameleon.

(translate: you shouldn't have problems with a passive miniDP-VGA. Keep in mind that you must use exact uppercase characters in "GraphicsEnabler=No" or Chameleon will ignore it. The same applies to chameleon's .plist)
Logged
calvintml
Full Member
***
Offline Offline

Posts: 131


« Reply #24 on: May 28, 2012, 02:01:22 PM »

Thanks for the bios. It is identical to mine.

There are no passive mini dp to vga adapters, they are all active, by necessity.
« Last Edit: November 22, 2012, 05:08:14 PM by calvintml » Logged
claudioazevedo
Newbie

Offline Offline

Posts: 3


« Reply #25 on: May 30, 2012, 05:04:49 PM »

Robocop2, i have tried the GraphicsEnabler=No in boot and edited in plist, none of these works. I also have tried replace the ATI5000Controller that calvintml posted, no luck too..
To boot Lion and see desktop i need to remove the ATI5000Controller kext and then os boots in some of "VGA mode".

calvintml, this is my VGA (http://www.powercolor.com/us/products_features.asp?id=240), i tried with the edited ATI5000Controller that you posted (x32 and x64 version), but when is to display the login screen, my monitor says that image is out of sync, without your edited ATI5000Controller, my monitor just turn itself off (like energy safe mode or something).

Can someone help me? I have updated the OS to 10.7.4.

(Bad english?!!? I know!)
« Last Edit: May 30, 2012, 05:14:01 PM by claudioazevedo » Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!