netkas.org forum
November 21, 2017, 04:42:19 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: MSI R5770 & ATI 5850  (Read 5185 times)
SMIKX
Jr. Member
**
Offline Offline

Posts: 78



« on: February 17, 2015, 12:31:14 PM »

( My last post regarding the MSI r5770 got deleted . .no idea why . )
I can confirm that the MSI r5770 boots up ( no boot screens ) in 10.6.8 on my 2.1 mac Pro Dual Quad 3 ghz. and after booting everything works perfectly. For example I use X-Plane and XP Verson 10 would barely run on my old ATI X1900T, now with the r5770 it runs on high settings without any noticeable glitches.

The r5770 WOULD NOT even boot up under any flavour of Lion 10.7 so there might be a diference between the Lion ATI drivers and this r 5770's ROM setup. I don't have Mountain Lion or Yosemite installed on this Mac Pro so no chance to test.

ATI 5850.

Won't boot at all in Lion 10.7.5
It booted twice in 10.6.8 but shortly thereafter no video  - black screen and a red flashing LED in the Mac Pro case. Power ? I DID have TWO 6 pin power cables attached from the MP motherboard.

I can live with no boot screens.

This MSI R5770 is almost completely silent, has two fans and a big extending heatsink. It comes factory over clocked. I got it for ¥5,400 ( about 50 bucks U.S.) here in Kyoto, Japan.

I have a feeling tht none of the available ROMS will yield EFI and boot screens.

When I have time, I'll save the ROM and try to create my own one. if it works with no lessening of performance I will post the ROM here.


Cheers.



« Last Edit: March 15, 2015, 04:33:30 PM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
HIS HD 7950 3Gb 5.0 GT/s EFI on mDP to DVI + DVI to DVI.
10.9.5 - 10.12.6  - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 809



« Reply #1 on: February 17, 2015, 02:41:38 PM »

No bootscreen for 1,1/2,1 mp after 4870 and before 7950

Just get 750ti, as powerfull as 5870 and uses 3 times less power, but needs 10.10 + webdriver
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 78



« Reply #2 on: February 17, 2015, 04:17:56 PM »

No bootscreen for 1,1/2,1 mp after 4870 and before 7950

Just get 750ti, as powerfull as 5870 and uses 3 times less power, but needs 10.10 + webdriver

Thanks for your trusted advice. .sadly I can't install Yosemite on my much loved MP 2,1 and my other Mac is a Corei5 Mac Mini but . .  I will on learning everything regarding ROMS. I salute your efforts on our behalves.

I'm not in any panic about not having bootscreens . .still got my X1900T with a 3rd, party .  very quiet cooler - fan array.
Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
HIS HD 7950 3Gb 5.0 GT/s EFI on mDP to DVI + DVI to DVI.
10.9.5 - 10.12.6  - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
tobyglyn
Newbie

Offline Offline

Posts: 13


« Reply #3 on: March 21, 2015, 06:35:05 AM »

With some fiddling around, you can run Yosemite on your Mac Pro 2,1.

https://www.youtube.com/watch?v=_XaAMe2bDPg

http://forums.macrumors.com/showthread.php?t=1740775
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 78



« Reply #4 on: March 25, 2015, 08:21:46 AM »

Yes, but I've already got Mavericks 9.5 and prefer it to Yosemite. Thanks for replying.
Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
HIS HD 7950 3Gb 5.0 GT/s EFI on mDP to DVI + DVI to DVI.
10.9.5 - 10.12.6  - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
KDragon75
Newbie

Offline Offline

Posts: 1


« Reply #5 on: March 31, 2015, 09:33:55 PM »

Did you ever get the ROM flashed and working during boot?
I just got this card and want as pure an Apple experience as possible.
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 78



« Reply #6 on: April 01, 2015, 02:08:35 AM »

Yes, the MSI R 5770 Hawk has now been flashed to EFI with DVI-VGA adapter. Works beautifully.

The ROM is here.

http://forum.netkas.org/index.php/topic,8810.0.html
« Last Edit: April 01, 2015, 02:08:15 PM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
HIS HD 7950 3Gb 5.0 GT/s EFI on mDP to DVI + DVI to DVI.
10.9.5 - 10.12.6  - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!