netkas.org forum
September 27, 2020, 08:25:19 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: iMac 24" early 2009 safe video card upgrade  (Read 5879 times)
Ipreferapples
Newbie

Offline Offline

Posts: 1


« on: January 22, 2014, 08:33:18 AM »

Hello guys, I was really happy to find you forum on the web. I have read a lot of topics about graphics card uptading in iMacs, but most of them related only for imacs of 2008 which have limited mxm slot. In my case I have perfect iMac 24" of early 2009, model 9.1, (by the way, I upgraded HDD to sata II ssd and ddr3 1066mhz to ddr3 1333mhz 8gb and it works perfect). However my videocard is GeForce GT120 (gddr3 256mb, 128bit) spoils everything. i can play games I have to use low graphics settings and lower resolutions because this card cannot perform any serious tasks. The official possible upgrade for this kind of imacs is:

1) GeForce GT130 512MB
2) Radeon 4850 HD 512MB

I want to minimize risk of update (I mean I dont need a card that not gonna work which I will have to re-sell) but still, maybe someone have expierence of upgrade to something different. As far as i know, radeon 6770 from 2011 imac was not working (some guy here complained that he cant make it work).
So now I am going to buy radeon 4850hd (thrown away from some laptop) but with 1gb memory (not 512 that is listed as top-lane modification of imac) and wonder if it will work or if it will be easy to flash to make it work, at least. And what about if I get 256-bit version of this card instead of 128-bit that I have now? Does this matter on compatiblity somehow?

As i got from specifications of geforce gt120, this imac PROBABLY can support most of cards up to radeon 7xxx-9xxx which is made for pcie up to 2.1. But the question is EFI. So, anyone, suggestions? Smiley

« Last Edit: January 23, 2014, 06:30:23 AM by Ipreferapples » Logged
LKJ
Newbie

Offline Offline

Posts: 1


« Reply #1 on: June 12, 2014, 12:37:06 AM »

Similar but parallel situ: 9,1 iMac, early 2009.  have a late 2009 27" 4850 GPU.  GTX 130 in my imac is crapping out, standard heat fatigue freezes.  I put the 4850 in, all 4 LED's come on, no image.  LED screen backlighting is working fine, can pull it and put the 130 back in and it works fine.  I can remote desktop in w/ the 4850 in place and it is recognized by the computer correctly, but no screen image.

I'd sort of like to figure this out myself, anyone willing to set me on the correct path?  Would I need just to alter the cards ID, reflash the EFI/BIOS, or just tweak a refresh frequency or something?

Many thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!