netkas.org forum
October 20, 2019, 11:31:04 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: RAID0 and guid bootloader, b0 error  (Read 6946 times)
Crazor
Newbie

Offline Offline

Posts: 4


« on: December 27, 2007, 08:37:06 PM »

With 10.4, I actually managed to make a bootable RAID0 with much hacking to get proper hybrid gpt/mbr etc., because at that time, the only bootloader available was the MBR one.

Now that we have a GPT-capable bootloader, I thought to give it a new try, this time on 10.5.

To start, I put the pc efi guid loader on a single-disk installation, just to make sure I understood the installation =) Worked like a charm.

Then I started hacking away at a RAID0, putting boot1h in the 3rd GUID partition which OSX creates on every disk for bootloader stuff, putting boot0 in the first sector (protective MBR) and embedded boot_v8 into the HFS+ filesystem inside the 3rd GUID partition, too. But all I manage is getting "b0 error"s.
Now, with an MBR loader, b0 usually means no active partition, but with GPT, there is no such thing as an active partition. What other reasons could be causing b0 errors?
Logged
Mr_jojo
Newbie

Offline Offline

Posts: 2


« Reply #1 on: January 02, 2008, 10:04:33 PM »

I also would like to know how to make efi 8.0 work with raid.

I have two identical 500gb drives, can i choise raid option when installing osx?

Does efi 8.0  produce a bootable disk ?

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!