netkas.org forum
June 23, 2017, 01:06:27 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: flash Sapphire 5850 using 5870 ROM?  (Read 17957 times)
1slittle
Newbie

Offline Offline

Posts: 1


« on: December 06, 2010, 10:23:03 PM »

I've seen people using the Radeon HD 5870 bios to overclock their Radeon HD 5850.
Is it possible to use the 5870 ROM to flash my 5850? I have a 2006 Mac Pro and am using a PC Sapphire 5850 in Vista64 through bootcamp. I'd like to flash it so I can use it natively in OSX as well... I'm assuming if this is possible then I'd just boot to dos and run atiflash -p 0 NEW.rom -f

I don't want to screw the card up as this isn't my forte... Has anyone done this? I've not seen much discussion on the 5850.

Thanks in advance...
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2123



« Reply #1 on: December 07, 2010, 03:44:17 AM »

blaze the trail
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
Rominator
Hero Member
*****
Offline Offline

Posts: 2123



« Reply #2 on: June 05, 2011, 11:02:23 PM »

Well, obviously this guy reached down and couldn't find a set.

I just came into a HIS 5850 and am going to try to flash it to work on Mac EFI.

My first attempts have been thwarted by a "sigsegv" message from atiflash. This is what happens when EEPROM or image is too large so I will find another way.

But these could be a less expensive option for people looking for 5870-like performance.

Does anyone else have a 5850 and want to join the effort?

(must have something resembling courage or sense of adventure)
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
macjunkie
Guest
« Reply #3 on: June 07, 2011, 08:57:57 PM »

Hey Rom!

Been their Done it Already!


My finding, using a non reference HD5850 will not work properly for me. I tried a Gigabtye HD5850 with the dual fans, got it booting in OSX but got a wierd flickering issue.

I then used a Powercolor reference design HD5850 card. I made a custom rom for it using the python script method, by sewing the original HD5850 PC rom with the HD5870 mac rom as we do for HD5870's
Then I did was open it in RBE & matched the ram/core/voltage to the original rom that was on the card & presto, flashed it with the modded rom & have been using it for 2 weeks, not a problem works triple display & both in bootcamp & OSX.
I haven't tried clocking up the setting to match the 5870. As I don't like overclocking cards.
All in all scores in lux & open gl very close to a genuine HD5870.

if some one can let me know how to upload my rom & post it, I can share it to all

My rom has 4000 memory / 750 core settings (stock 5850)

this site mentioned that the HD5850 & HD5870 are idenitcal cards, same gpu chip, same memory up to 5000mhz capable only difference actual power handling, 5870 has larger power board & PCB & of course 1440 vs 1600 shaders

http://www.xbitlabs.com/articles/graphics/display/radeon-hd5850.html

so you probably can overclock it a fair bit.
« Last Edit: June 08, 2011, 11:44:19 AM by macjunkie » Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2123



« Reply #4 on: June 08, 2011, 02:26:19 AM »

when you post here, if you hit "Additional options", you can attach things.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
macjunkie
Guest
« Reply #5 on: June 08, 2011, 11:32:20 AM »


this is possible as you know 10.6.7 has the device ID for the 5850 6899

remember standard 5850 clock/memory speeds 4000mhz/750hmz

based on reference design Powercolor HD5850, should work on other reference design cards
« Last Edit: June 13, 2011, 12:56:53 PM by macjunkie » Logged
fhenry
Newbie

Offline Offline

Posts: 37


« Reply #6 on: June 24, 2011, 09:23:17 AM »

hello,

I have a sapphire 5850 extrem, i will try to flash it soon. You will have some news in 1 or 2 month when I will be in hollyday and have some time.


Fred
Logged
chrissomatic
Newbie

Offline Offline

Posts: 1


« Reply #7 on: August 03, 2011, 10:15:25 AM »

Someone is selling these flashed on eBay, so I assume this is doable. I don't know why they'd be selling a dead card.
Logged
wenlez
Newbie

Offline Offline

Posts: 5


« Reply #8 on: October 23, 2011, 10:06:49 PM »

I can't seem to find a 5850 EFI rom. any idea? I tried using the 6770EFI rom to flash my XFX HD5850 ROM, but the final ROM image is flashable by WinATIflash.
Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #9 on: November 09, 2012, 08:50:04 PM »

Bit old thread, but I have a little update which may be interesting for some.

I've flashed reference Sapphire 5850 with hybrid 5850/5870.rom that I've made exactly that same as macjunkie. Tested and working great in 10.7.5, Mac Pro 1,1.
My card stock clocks were 725/1000. I've OCed it to 850/1000 to match core clock of 5870. When I was trying to OC memory, first to 1200, then lower, to 1100, I got flickering on lower DVI port (I use dual displays via DVI). With core OCed and memory clock intact, flickering does not appear.

Card works great in OCL and OGL, below are screens from benches (stock vs OCed clocks + Unigine @850 core).

But there's one thing that is bothering me: why Luxmark "room" scene is so low? Rest is pretty good.



* lux1 (68.07 KB, 1119x536 - viewed 523 times.)

* lux2.jpg (69.84 KB, 1091x535 - viewed 451 times.)

* lux3.jpg (34.43 KB, 594x536 - viewed 460 times.)

* 5850unigine.jpg (77.25 KB, 442x552 - viewed 505 times.)
« Last Edit: November 09, 2012, 08:53:53 PM by blacksheep » Logged
Subconnect
Newbie

Offline Offline

Posts: 1


« Reply #10 on: January 05, 2013, 06:47:40 AM »

Hey, I'm pretty new to this but I traded my dad my 2012 Mac Mini for is 2006 Mac Pro 1, 1 (He wanted my mac mini cause it was small and moveable). Anyways I already got Windows running (64bit) and I wanted to buy a radeon 5850 only cause I can get one for $90. Of course I want to flash it so I can use in OSX and Windows 7. How can I get this rom file from you?
Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #11 on: January 05, 2013, 03:17:00 PM »

Hey, I'm pretty new to this but I traded my dad my 2012 Mac Mini for is 2006 Mac Pro 1, 1 (He wanted my mac mini cause it was small and moveable). Anyways I already got Windows running (64bit) and I wanted to buy a radeon 5850 only cause I can get one for $90. Of course I want to flash it so I can use in OSX and Windows 7. How can I get this rom file from you?

My ROM is card-specific. If you want 5850, get reference card (like one from macjunkie's picture, brand doesn't matter), dump ROM and upload it here. I'll make an EFI ROM for your card.
Logged
im82IsNotABot
Newbie

Offline Offline

Posts: 1


« Reply #12 on: July 20, 2014, 08:28:53 PM »

Helloes,

do you still help people out with custom roms?

I got Windows and 10.9.4 running on my hackintosh but have issues with ultra wide resolutions, ghost displays and HDMI sound out etc.

How do I dump the rom (which windows tool)?

My card is an Sapphire AMD/ATI Radeon 5850 Xtreme 1GB DDR5 HDMI/DVI/DP
http://www.sapphiretech.com/presentation/product/product_index.aspx?pid=1152&lid=1
Logged
leo1984
Newbie

Offline Offline

Posts: 8


« Reply #13 on: August 26, 2016, 09:21:26 AM »

Bit old thread, but I have a little update which may be interesting for some.

I've flashed reference Sapphire 5850 with hybrid 5850/5870.rom that I've made exactly that same as macjunkie. Tested and working great in 10.7.5, Mac Pro 1,1.
My card stock clocks were 725/1000. I've OCed it to 850/1000 to match core clock of 5870. When I was trying to OC memory, first to 1200, then lower, to 1100, I got flickering on lower DVI port (I use dual displays via DVI). With core OCed and memory clock intact, flickering does not appear.

Card works great in OCL and OGL, below are screens from benches (stock vs OCed clocks + Unigine @850 core).

But there's one thing that is bothering me: why Luxmark "room" scene is so low? Rest is pretty good.
Sorry for reviving such an old thread, but i'm stuck trying to let a 5850 work with my 1,1 mac pro (10.7.5). unfortunately the card is not a reference model: Saphire Toxic 5850 1 Gb
bios is here:
https://www.techpowerup.com/vgabios/69326/sapphire-hd5850-1024-100124
could you please help me in the creation of a efi rom?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!