netkas.org forum
July 28, 2017, 05:42:47 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 41 42 [43]
  Print  
Author Topic: 7xxx rom creating test.  (Read 350365 times)
SMIKX
Jr. Member
**
Offline Offline

Posts: 54



« Reply #630 on: July 13, 2017, 07:06:43 PM »

Success !  My R9 270X 2gb  is now EFI booting but thanks to Netkas & whomever created the upgraded "Bundle2" ( searched but now can't find him ).

Working :

1. Displays "R9 270X" in Sys Info. ( Edited the rom with Hex Fiend changed incidences of "7950" to "R9 270X" )

2. Bootscreen in bottom DVI to DVI.

3. Bootscreen if using one monitor Displayport to HDMI adaptor to monitor HDMI input.

4. With two monitors connected the DVI - DVI is first to show bootscreen then the DP to HDMI adaptor kicks in.
    I have yet to try with a dedicated Display port to HDMI cable. I'll buy one soon.

5. Oceanwave full screen AA shows 62 fps  - enough for my needs

Not working.

5. Upper DVI

6. HDMI to HDMI ( worked OOTHB before being flashed )

==================

This R9 270X is made by a Japanese company that is always cheaper than the big players. I got it for about US$60 ( I live in Japan ).
This is the website for my card http://www.kuroutoshikou.com/product/graphics_bord/amd/rd-r9-270x-e2gb_oc/

EDIT 1 : Next project will be to find the R17 resistor!

EDIT 2: On the back of the card I found a WHITE TEXT  list showing R16 & R 17 in an outlined box with an upper case "A" listed perhaps as a resistor group location map ( no idea yet )  but after checking both sides ( with fan removed ) still can't find R 17. I have no idea what the WHITE TEXT signifies .. I'll Google for info but any advice very welcome.



* Oceanwave AA full screen 61.5 fps.jpg (199.26 KB, 826x656 - viewed 16 times.)

* 01 PCI report Flashed with correct name.jpg (98.87 KB, 723x574 - viewed 19 times.)

* 02 Craphics-displays report Flashed with correct name.jpg (171.02 KB, 726x657 - viewed 12 times.)

* 02 PCI report Flashed with correct name.jpg (106.22 KB, 727x576 - viewed 13 times.)

* Displayport to HDMI adaptor SML.JPG (92.89 KB, 1024x355 - viewed 14 times.)

* R9 270X About this Mac.jpg (86.11 KB, 582x334 - viewed 19 times.)

* White print 01.jpg (71.96 KB, 250x319 - viewed 11 times.)
« Last Edit: July 15, 2017, 04:34:19 PM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
Radeon R9 270X 2Gb EFI on DP to HDMI. DVI to DVI.
10.12.5 - 10.9.5 - 10.12.5 - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
nekton1
Jr. Member
**
Offline Offline

Posts: 51


« Reply #631 on: July 14, 2017, 12:06:14 AM »

Please post the rom you made.

vinnie1978

Thanks so much for your reply . . .  I actually knuckled down and boned up on Terminal commands and using "Bundle2" ( upgraded "bundle" ) targeting the " efiromheader_7950.rom " and working in Terminal in 10.6.8 ( my favourite OS X personality ) .. succeeded !

I flashed in a dedicated Win7 HDD on my cMP ( I don't like Bootcamp ) using AtiWinFlash.

I used Hex Fiend to edit the two incidences of " 7950 " to " R9 270X ".

 I have the R9 280X booting efi with the correct name in Sys Info  and running two monitors; One from DVI - DVI ( lost the top DVI port ) and another monitor using a Displayport to HDMI adaptor.

I'll post some pics in this thread in about 30 minutes.

I got this card here in Japan for ¥6,900  .. roughly US$60.

The card is reference but no bios switch like the MSI version. It comes overclocked to a base 1030Mhz  - to 1080Mhz in boost mode. Here is the card http://www.kuroutoshikou.com/product/graphics_bord/amd/rd-r9-270x-e2gb_oc/


( I also have this company's 2 port USB 3.1 PCIe card with Asmedia 1142  running in my cMP 4,1 flashed to 5,1. I got it for ¥1,400 !  It works brilliantly beside a 4 port Inateck FL1100.
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 54



« Reply #632 on: July 14, 2017, 01:16:08 AM »

nekton 1

What's your Mac Pro setup ? ( you should fill out your profile in your forum settings. )

EDIT : Have you tried using Netkas's script ? ( no pain, no gain ).
« Last Edit: July 14, 2017, 02:01:14 AM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
Radeon R9 270X 2Gb EFI on DP to HDMI. DVI to DVI.
10.12.5 - 10.9.5 - 10.12.5 - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
SMIKX
Jr. Member
**
Offline Offline

Posts: 54



« Reply #633 on: July 14, 2017, 05:36:50 AM »

I just discovered that my R9 270X is showing bootscreen on the Display port to HDMI adaptor !  I expected that DVI to DVI would be the bootscreen. Live & learn. I bought the DP to HDMI adaptor two years ago on a whim .. I'm glad I kept it now.
EDIT : DP - DP to HDMI adaptor - HDMI Bootscreen OK if only ONE monitor  connected.
                    Same with DVI - DVI ifonly one monitor connected.


Also checked it in Sierra 10.12.5 for Metal support and it's OK


* 03 Sierra.jpg (91.59 KB, 516x441 - viewed 11 times.)

* 01 Sierra.jpg (102.38 KB, 580x351 - viewed 11 times.)
« Last Edit: July 15, 2017, 04:48:05 PM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
Radeon R9 270X 2Gb EFI on DP to HDMI. DVI to DVI.
10.12.5 - 10.9.5 - 10.12.5 - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
nekton1
Jr. Member
**
Offline Offline

Posts: 51


« Reply #634 on: July 15, 2017, 07:08:20 AM »


Same as you.

Kurotoshiko RD-R9-270X-E2GB/OC GPU (I live in Toyo), cMP 5.1, 32 GB RAM, macOS 10.13


nekton 1

What's your Mac Pro setup ? ( you should fill out your profile in your forum settings. )

EDIT : Have you tried using Netkas's script ? ( no pain, no gain ).
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 54



« Reply #635 on: July 15, 2017, 02:33:56 PM »

Nekton

I'm in Kyoto, 37°C in my garden today !  

I'm jealous that you're closer to Akihabara than me. The best option I have for bargain hunting is "Den Den Town " in Osaka but even that's over an hour away by express.

Have you got your R9 270X showing bootscreens ?

If so, on what ports ? Using any adaptors ?
« Last Edit: July 15, 2017, 04:48:37 PM by SMIKX » Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
Radeon R9 270X 2Gb EFI on DP to HDMI. DVI to DVI.
10.12.5 - 10.9.5 - 10.12.5 - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
DavNeil
Newbie

Offline Offline

Posts: 7


« Reply #636 on: July 20, 2017, 07:03:46 AM »

Nekton

I'm in Kyoto, 37°C in my garden today !  

I'm jealous that you're closer to Akihabara than me. The best option I have for bargain hunting is "Den Den Town " in Osaka but even that's over an hour away by express.

Have you got your R9 270X showing bootscreens ?

If so, on what ports ? Using any adaptors ?


I just had weird thought, can I buy the card from US. R9 280X? Is there a english translation button? Thanks.
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 54



« Reply #637 on: July 20, 2017, 12:00:04 PM »

Why do you need a translation ?  A card is a card. You could download an English manual from a 'worldwide" retailer ( Sapphire, Gigabyte etc.  just plug it in.

I can't remember needing to refer to any manuals in my long time in Japan ( though I do keep them in case I re-sell a card ).
Logged

Mac Pro 4,1 upped to 5,1 Dual Quad Core 2.93ghz 17Gb 480Gb SSD TRIM enabled.
Radeon R9 270X 2Gb EFI on DP to HDMI. DVI to DVI.
10.12.5 - 10.9.5 - 10.12.5 - 10.6.8 - Win 7 not Bootcamp. 
AREA 2 port USB 3.1 & Inateck USB 3.0 4 port in OS X 10.9.5.
Pages: 1 ... 41 42 [43]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!