netkas.org forum
June 25, 2022, 11:10:35 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 33 34 [35] 36 37 ... 47
  Print  
Author Topic: 7xxx rom creating test.  (Read 1293715 times)
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #510 on: April 08, 2016, 01:09:38 AM »

You used wrong EFI.

There is a 7950 one and a 7970 one.

Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
MacPenguin
Not Newbie
*
Offline Offline

Posts: 9


« Reply #511 on: April 08, 2016, 06:53:48 AM »

Hi Rominator,

Sorry if I sound like an idiot, but I have re-read this whole thread 3 or 4 times and I haven't found any HD 7970 specific EFI.

In the bundle, there's only the 7950.efi file, not 7970 EFI file.

In this post (http://forum.netkas.org/index.php/topic,5619.msg19874.html#msg19874) you are providing a 7970 specific MAC, but that's not EFI is it ?

So am I missing something ?

Thanks a lot a lot for all the help you're providing...

Regards.
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #512 on: April 08, 2016, 07:32:21 AM »

It's out there.

I have posted it a few times.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
MacPenguin
Not Newbie
*
Offline Offline

Posts: 9


« Reply #513 on: April 08, 2016, 08:10:19 AM »

Hi Rominator,

I really wish to thank you for all your efforts.

I haven't been able to find the 7970 specific EFI even after carefully looking at the attached files of your posts or the links in your posts.
The only one I found is the 7970MAC.ROM file, but that one doesn't work, either used as a standalone file or as a base to flash with my own dumped .rom file.

Basically, the 7970 flashed with 7950 EFI works, and it has a bootscreen.

But I am under the impression that MacOS doesn't really know what card is used and so gets a little messy. Unigine results are really too variable (from 1250 to 1650) to consider it a stable solution.
Besides, there is no audio output on any port : nor mini DP nor HDMI.
And as a last problem : there seems to be a distorsion between the hardware and the software and that makes the card impossible to use with Linux.

SO all in all, and despite your efforts, that card isn't something for me, as I need sound, Linux compatibility and (if possible) stable results.
Of course, if there's a 7970 specific .efi file that would address these issues, I'd be glad to test it.

But as I said : I haven't been able to find it...

Will maybe consider a GTX 680 :-(

Regards.

FRED
« Last Edit: April 08, 2016, 09:30:21 AM by MacPenguin » Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #514 on: April 08, 2016, 10:05:04 AM »

680 wont have sound either.

RESEARCH is key.

Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
MacPenguin
Not Newbie
*
Offline Offline

Posts: 9


« Reply #515 on: April 08, 2016, 10:44:22 AM »

Hi Rominator,

If the GTX 680 won't have sound, it's a no go either. But maybe it'll boot into Linux ?  

I will do some more research on the entire forum...

But for now, it seems the best option is to flash back the original ROM the card came with and put it again on that same ad site I found it from...

A lot of time wasted, but it has been fun :-)

« Last Edit: April 08, 2016, 10:50:23 AM by MacPenguin » Logged
HAL2001
Not Newbie
*
Offline Offline

Posts: 25


« Reply #516 on: April 08, 2016, 02:36:05 PM »

Can someone confirm that the Sapphire 11196-09-40G card is flashable with bootscreens?

Thanks!
Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 406


« Reply #517 on: April 08, 2016, 08:43:28 PM »

Can someone confirm that the Sapphire 11196-09-40G card is flashable with bootscreens?

Thanks!

Yes, HDMI and upper DVI will be dead.
Logged
MacPenguin
Not Newbie
*
Offline Offline

Posts: 9


« Reply #518 on: April 08, 2016, 09:27:44 PM »

Hi guys,

Anyone who'd be so kind to answer one simple question ?

IS THERE OR IS THERE NOT A RADEON HD7970 SPECIFIC .efi ?

I am asking because Rominator says there is... and I've seen several posts on this forum (not in this thread) where he says he has uploaded it.
But if he did, he has hidden the file good... and I seem not to be the only one not finding it...
On the other hand, there are several posts stating that there is no 7970 specific .efi file. That one can just flash a 7970 with the 7950.efi and that the card will run at full speed.
And then, on that same page, Rominator wrote a post where I understood NOTHING (you know guys, I know notting ! NOTTING ! I'm from Barcelona...). Something about an UEFI and a Mac efi... stating it can't be simpler. Well I guess it can for a noob like me :-(
(For all this, see posts 406 to 419 on this thread).

By the way : if this .efi exists... would you be so kind to point me into the right direction to get it ?

I'll bless the one doing it with my eternal gratitude !

Regards.
« Last Edit: April 08, 2016, 09:31:03 PM by MacPenguin » Logged
armdn
Full Member
***
Offline Offline

Posts: 149


« Reply #519 on: April 12, 2016, 09:13:38 AM »

Can someone confirm, will this card works after flash: Sapphire 11198-10-40G??

It looks like reference, but additional DVI-D port and new PCB...
Logged
armdn
Full Member
***
Offline Offline

Posts: 149


« Reply #520 on: April 12, 2016, 10:50:10 AM »

Can someone confirm, will this card works after flash: Sapphire 11198-10-40G??

It looks like reference, but additional DVI-D port and new PCB...

Answer to myself and anyone who interested: DO NOT BUY this card. EFI menu will work, but OS X will get Kernel Panic when frame buffer start loading.
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #521 on: April 12, 2016, 08:01:26 PM »

And for the 100th time.

GET REFERENCE CARDS !

CARDS WITH SINGLE DISPLAYPORT WILL FREQUENTLY NOT WORK WITH THE DRIVER AT ALL.

Stick with the reference outputs or prepare for sorrow.

Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
MacPenguin
Not Newbie
*
Offline Offline

Posts: 9


« Reply #522 on: April 12, 2016, 08:37:17 PM »

And even with reference cards, sorrow may wait ahead if you want some special features, like the ability to triple boot with the same card :-(
Logged
armdn
Full Member
***
Offline Offline

Posts: 149


« Reply #523 on: April 14, 2016, 05:02:48 AM »

And for the 100th time.

GET REFERENCE CARDS !

CARDS WITH SINGLE DISPLAYPORT WILL FREQUENTLY NOT WORK WITH THE DRIVER AT ALL.

Stick with the reference outputs or prepare for sorrow.



There was two minidp outputs. And yet it was not reference. Sapphire makes gomunkulus.
Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 406


« Reply #524 on: April 14, 2016, 11:28:58 PM »

And for the 100th time.

GET REFERENCE CARDS !

CARDS WITH SINGLE DISPLAYPORT WILL FREQUENTLY NOT WORK WITH THE DRIVER AT ALL.

Stick with the reference outputs or prepare for sorrow.


The only which isn't working so far in our test is the Sapphire HD7950 with one DisplayPort and Boost: http://cdn.videocardz.com/1/2013/02/Sapphire-HD-7950-Boost-3GB-4.jpg - it doesn't even boot unflashed.

Others does work, but sometimes you've got disabled DP or HDMI and always upper DVI if it exists.
Logged
Pages: 1 ... 33 34 [35] 36 37 ... 47
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!