netkas.org forum
May 28, 2022, 10:47:29 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 27 28 [29] 30 31 ... 47
  Print  
Author Topic: 7xxx rom creating test.  (Read 1284096 times)
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #420 on: August 12, 2015, 09:46:16 AM »

Yeah, that might be the reason. Just had a look, my R9 280 has a different ID: 11230-00-20G
I'll upload my ROM later, with a bit of luck it'll be compatible with your card (much can't wrong due to dual bios anyway Smiley).
Logged
smjones
Not Newbie
*
Offline Offline

Posts: 10


« Reply #421 on: August 14, 2015, 10:49:19 AM »

The Sapphire 11230-00-20G is exactly the card I'm working with. Also marked as 100373L.

However, I've stalled because my MacPro 4,1->5,1 has apparently lost it's damned mind. I've reverted back to the original GT 120, W3520, and RAM but it won't boot Yosemite. May show the progress bar under the Apple logo for a short or long time, but eventually it will reset, give chimes, rinse, repeat. If I boot the Yosemite installer from a USB stick, it can't see the hard drive. Past the return period too. Hmm...

(And that's not all - the Gigabyte GTX 750 Ti that I finally bought for my Linux box appears to be DOA. Target machine won't pass POST with it installed, nor will a Dell PWS 690. Sigh...)


So, I will get back to the Sapphire shortly. But the Gigabyte is working with both Yosemite and Windows 7 in the MacPro 1,1->2,1. Bootscreen on one display, using mDP -> DVI adapters by Rosewill.

Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #422 on: August 24, 2015, 06:47:29 AM »

So after reading through this thread I bought this card:
Sapphire Technology AMD Radeon HD 7950 3 GB with Boost 11196-16-20G (HDMI Standard Output, DVI Output, DisplayPort Output)

The seller on eBay listed as having miniDisplayPort so I thought this would be a good card. Turns out it has regular Displayport, Doh!  Shocked So not at all close to reference mac card.

Bottomline is can’t get it to boot with a boot screen on MacPro1,1 after flashing other’s roms on the thread or by making my own or using Rominator’s from post 2. And after re-reading the thread I see that I’m sunk, no one has successfully gotten this card to show boot screen on mac. So I’m fine with using it without boot screens or I may resell it.

BUT! If anyone has made magic with a bootrom for this exact card I’d love to hear.

Here's what I've found on this thread to be WORKING  CARDS
Sapphire Radeon HD 7950 3GB GDDR5 (11196-00-20G)
Sapphire Radeon HD 7950 3GB GDDR5 (11196-19-20G)
Sapphire Radeon HD 7950 3GB GDDR5 (11196-09-40G)
Sapphire Radeon HD 7950 3GB GDDR5 (21196-00-20G)
Sapphire Radeon HD 7950 3GB GDDR5 (11196-16-20G) (UPDATE: MY CARD GOT IT TO FLASH!)
SAPPHIRE Radeon HD 7950 100352-2L
MSI 7950 TwinFrozr OC

Can anybody add to this? A lot of the posts don't list specific model numbers. I'm trying to find the cheapest one I can find that will flash to show apple startup.

« Last Edit: August 26, 2015, 12:37:58 AM by buzzworm » Logged
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #423 on: August 24, 2015, 07:57:46 AM »

I'm pretty sure that bootscreens can be enabled on at least a few ports. Did the flashing work at all (=> does it report as "HD 7950" now in system profiler?).
You can attach your ROM here, I'll have a look later.
Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #424 on: August 24, 2015, 03:20:05 PM »

The flashing said it was successfull but sys profiler reports it as 7xxx. see photo.

I've attached original rom "Tahiti" and the rom I built using Netkas' script "Saphire7950.rom". I used ATIwinflash to flash it.
Thanks so much for giving it a look Smiley


* Screen Shot 2015-08-24 at 7.16.19 AM.png (111.18 KB, 1224x600 - viewed 1660 times.)
* Tahiti.rom (128 KB - downloaded 699 times.)
* Saphire7950.rom (128 KB - downloaded 772 times.)
Logged
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #425 on: August 24, 2015, 04:12:55 PM »

There must have been an error when creating the EFI ROM.
Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #426 on: August 24, 2015, 04:53:10 PM »

The first time I got "permission denied" errors etc. But I moved it to a different user, ran the script and got no errors in the terminal window. I'll do it again and post the results, then reflash and report back.
Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #427 on: August 25, 2015, 04:34:59 AM »

I rebuilt the rom using Netkas script and this time it worked!  Cheesy
Not sure what I did wrong... It's weird because I opened the old rom from yesterday I created and compared with the new rom I made tonight using hex fiend and they both looked exactly the same. When I ran the script yesterday there were no errors so still not sure, but glad it worked this time!

Thanks Rominator, Netkas, Florian for your genius. Smiley
« Last Edit: August 25, 2015, 04:49:41 AM by buzzworm » Logged
HenryGuy
Newbie

Offline Offline

Posts: 2


« Reply #428 on: August 26, 2015, 12:21:11 AM »

So after reading through this thread I bought this card:
Sapphire Technology AMD Radeon HD 7950 3 GB with Boost 11196-16-20G (HDMI Standard Output, DVI Output, DisplayPort Output)

The seller on eBay listed as having miniDisplayPort so I thought this would be a good card. Turns out it has regular Displayport, Doh!  Shocked So not at all close to reference mac card.

Bottomline is can’t get it to boot with a boot screen on MacPro1,1 after flashing other’s roms on the thread or by making my own or using Rominator’s from post 2. And after re-reading the thread I see that I’m sunk, no one has successfully gotten this card to show boot screen on mac. So I’m fine with using it without boot screens or I may resell it.

BUT! If anyone has made magic with a bootrom for this exact card I’d love to hear.

Here's what I've found on this thread to be WORKING  CARDS
Sapphire Radeon HD 7950 3GB GDDR5 (11196-00-20G)
Sapphire Radeon HD 7950 3GB GDDR5 (11196-19-20G)
Sapphire Radeon HD 7950 3GB GDDR5 (11196-09-40G)
SAPPHIRE Radeon HD 7950 100352-2L
MSI 7950 TwinFrozr OC

Can anybody add to this? A lot of the posts don't list specific model numbers. I'm trying to find the cheapest one I can find that will flash to show apple startup.



I have the SAPPHIRE Radeon HD 7950 100352-2L in great condition and want to flash the bios for resale. Have cleaned it to like new status, never had any issues what so ever with it. I see the flashed MAC cards get way more cash than the normal cards and I'd like to cover my costs on my new card.

So I use the utility in the OP of this thread coupled with my bios to flash it for MAC with boot screen? Simple as that? PS I can flash bios easy, I am extremely tech savvy.
Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #429 on: August 26, 2015, 12:40:13 AM »

Yep. It's all laid out in the thread. Take an hour and speed read.

this is pretty much it (copied this from a previous post)

1. Dump rom of card using  GPU-Z in Windows
2. Create composite rom using Netkas Script in OS X
3. Use ATI WinFlash to update rom in Windows (Make sure to type correct deviceID)
     atiwinflash -f -p 0 bios.bin
replace "bios.bin" with name of your rom you created with Netkas Script

or just use Rominator's rom on post 2 and flash. I had to use the above to get mine to flash with boot screens.
« Last Edit: August 26, 2015, 12:42:34 AM by buzzworm » Logged
HenryGuy
Newbie

Offline Offline

Posts: 2


« Reply #430 on: August 26, 2015, 12:44:30 AM »

Yep. It's all laid out in the thread. Take an hour and speed read.

this is pretty much it (copied this from a previous post)

1. Dump rom of card using  GPU-Z in Windows
2. Create composite rom using Netkas Script in OS X
3. Use ATI WinFlash to update rom in Windows (Make sure to type correct deviceID)
     atiwinflash -f -p 0 bios.bin
replace "bios.bin" with name of your rom you created with Netkas Script

or just use Rominator's rom on post 2 and flash. I had to use the above to get mine to flash with boot screens.

Ah that was where my confusion started. I read up til page 10 and it seemed like it requires access to a MAC.

I'm going to try and find somebody who has one so I can do it. Any tips? I pretty much am already done with doing this.
Logged
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #431 on: August 26, 2015, 12:20:10 PM »

You might be able to run the script on Windows (Linux would work for sure), but you'd definitely want to test the card in a MacPro.
There's no way to tell that flashing was successful when using a PC. Especially test all ports of your card, some might be non-functional if your card doesn't match reference layout.
Logged
buzzworm
Not Newbie
*
Offline Offline

Posts: 6


« Reply #432 on: August 29, 2015, 03:16:23 AM »

So I just plugged in my 30" Cinema Display  (2560x1440) to the Sapphire Radeon HD 7950 3GB GDDR5 (11196-19-20G) on it’s only working DVI port and it's showing whitish pixels all over the place. When I play a video it displays reddish dots. At boot, it shows the Apple Logo along with vertical lines across the screen, like banding.

If I plug a 23” (1920x1080) Cinema Display it works fine.

I thought it might be something to do with Dual Link DVI, but my 30” is plugged into the White DVI port which I believe is Dual Link. The black DVI port doesn’t work at all. Which one is Dual Link?

Anybody got any ideas or should I just get a card with MiniDisplay port? I purchased this from an eBayer who said it was a 11196-16-20G model but it's actually a 11196-19-20G which doesn't have minidisplay ports.
« Last Edit: August 29, 2015, 03:19:08 AM by buzzworm » Logged
ngokchau
Newbie

Offline Offline

Posts: 1


« Reply #433 on: August 29, 2015, 10:43:31 PM »

Thank you so much for creating this tool!

I have just purchased the AMD Radeon 7970, and hoping that all I have to do is stick it into my Mac Pro (how silly of me). My Mac powered up fine, but I see nothing on my monitors. After much reading and multiple articles pointing to this thread, I believe I need to flash my card. I have downloaded the bundle posted by netkas on page 1, downloaded the original rom from https://www.techpowerup.com/vgabios/125112/powercolor-hd7970-3072-120628.html, found the device id from the System Information tool on the Mac, and executed the makerom.sh script. The script generated a original.rom.efi.rom file. I'm not so sure what to do with this file.

Thanks in advance for helping!
Logged
soldi3r23
Newbie

Offline Offline

Posts: 4


« Reply #434 on: August 30, 2015, 07:34:05 PM »

Hello Forum Members, and Netkas and Rominator.

It has been quite a long time since I've re-flashed a Graphics Card for my mac, I've completed it on the 5770 already but now I've lost my instructions, I've read this posting and I am still confused.  

I've just recently updated my graphics card to a 7970, and would like explicit instructions on how to update the graphics card.  I am in no way a graphics card guru.  Can someone give me explicit full detail instructions on how to flash my Diamond 7970 Graphics Card.

I've downloaded the bundle that Netkas has posted and also the mac7950efi.rom file.  

The bundle zip file contains fixrom.py script and also makerom.sh script.

I have pc which I've downloaded the original rom file through GPU-Z and saved it as  into the folder called bundle,  where the rom file's name is "Tahiti.rom"(This is non-modified stock rom file)

 

Please give me as detailed instructions as possible, I am not sure where to go from here.  


I've attached my original 7970 Rom file, if anyone needs it or if anyone wants to help me by patching it up.  

Thank you so much for your help in advance.

*****Solved*******


Was as simple as can be.  All I needed was the Java SDK and ran the script like in the directions and changed my rom name to reflect thr original rom name "Tahiti.rom" the script did the rest.

Thank you Netkas, Rominator, and the rest of the users.


Thank you all!!!!


Smiley




* Tahiti.rom (128 KB - downloaded 725 times.)
« Last Edit: August 30, 2015, 08:44:55 PM by soldi3r23 » Logged
Pages: 1 ... 27 28 [29] 30 31 ... 47
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!