netkas.org forum
December 05, 2020, 06:18:10 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 21 22 [23] 24
  Print  
Author Topic: 5770 efi rom  (Read 469046 times)
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #330 on: February 28, 2012, 10:25:23 AM »

MD5(post #323 file) == MD5(My untouched ROM file)

I think you accidentally posted the wrong file? :-)


I'm sorry. My fault. I posted your rom and trashed the EFI-Rom I made for you.

My apologies Smiley.

lol, rom u need more of the valium/ritalin stuff Cheesy. Just kiddin' Wink.
Logged
dme88
Newbie

Offline Offline

Posts: 4


« Reply #331 on: February 28, 2012, 02:46:49 PM »

Success. But I still think it should have worked when i relocated the last "mcuc" part, even if there's space available. Donation made.  Smiley
Oh, and RomCreator.app is broken for 5770 then.
« Last Edit: February 28, 2012, 02:49:19 PM by dme88 » Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #332 on: February 28, 2012, 03:49:08 PM »

Success. But I still think it should have worked when i relocated the last "mcuc" part, even if there's space available. Donation made.  Smiley
Oh, and RomCreator.app is broken for 5770 then.

My guess is that you forgot to change the offset of the second "MCUC" after you moved the block Wink.
Logged
andychan
Newbie

Offline Offline

Posts: 4


« Reply #333 on: May 09, 2012, 12:22:15 PM »

a big Thank You to jeanlain for creating the script and documenting the procedure to make your own ROM !

just in case anyone is interested in how I made the ROM for my card using jeanlain's method and the "Vervet" EFI part -

this is my card:
http://forum.netkas.org/index.php/topic,371.msg11362.html#msg11362

you can find my ROM here:
http://forum.netkas.org/index.php/topic,692.msg11405.html#msg11405

here's my ROM-making process:
1. put my 5770 into a Lenovo ThinkCentre M58e tower PC (which is installed with Windows XP) with onboard Intel graphics and 1x PCIe x16 slot

2. connected the power to the 5770 with a 4 pin PSU to PCIe power supply converter cable that comes with my 5770
http://www.newegg.com/Product/Product.aspx?Item=N82E16812201004

3. started the Lenovo PC and went into BIOS, changed the video card to "PEG/Onboard"

4. booted up Windows XP and installed the ATI driver & Catalyst Manager

5. upon restarting the PC, Windows XP was able to detect a "ATI Radeon 5000" display adapter

6. ran GPU-Z, extracted the ROM and renamed it to "PC5770.rom"
http://www.techpowerup.com/downloads/2137/TechPowerUp_GPU-Z_v0.6.2.html

7. placed the following files in the root of my "IMATION1" thumb drive:
m5770_efi_vervet_p.rom (provided by netkas) -> http://forum.netkas.org/index.php/topic,374.msg2672.html#msg2672
PC5770.rom (which was extracted using GPU-Z in step 6 above)
fixrom.py (from flash.zip provided by jeanlain) http://forum.netkas.org/index.php/topic,692.msg3859.html#msg3859

* at this point, my 5770 card is still in the Lenovo PC

8. took my thumb drive and stuck it in my Mac Pro then launched Terminal

9. pasted the following commands into the Terminal window
cd /Volumes/IMATION1
blocknum=`printf %d "'\`dd if=PC5770.rom bs=1 skip=2 count=1 2>/dev/null\`"`
size=$(($blocknum * 512))
dd if=m5770_efi_vervet_p.rom of=PC5770.rom bs=$size seek=1 conv=notrunc

10. open "PC5770.rom" from my thumb drive in TextEdit, searched for "mcuc" and verified that there are only 2 instances

11. pasted the following command into the Terminal window
python fixrom.py PC5770.rom EFI5770.rom

Before:
OpRom (size=63488, indicator_offset=0x1ed, indicator=0x80, checksum=0xff)
OpRom (size=43008, indicator_offset=0x31, indicator=0x80, checksum=0xff)
RawData (size=24576)

After:
OpRom (size=63488, indicator_offset=0x1ed, indicator=0x0, checksum=0x7f)
OpRom (size=43008, indicator_offset=0x31, indicator=0x80, checksum=0x41)
RawData (size=24576)

* "EFI5770.rom" was created in my thumb drive

12. took my thumb drive back to the Lenovo PC, and burned a CD with the following files in it
ATIFlash.exe
http://www.techpowerup.com/downloads/2099/ATIFlash_3.95.html
EFI5770.rom

13. I have a  FreeDOS Beta 8 CD on hand, so I booted the Lenovo PC with the FreeDOS Beta 8 CD

14. when FreeDOS starts, it allows me to choose the bootup type,
so I pressed '1' for "Boot Dos with CD-ROM support (standard kernel)"
then '1' again to "BOOT WITH EL-TORITO CD-ROM DRIVER (DEFAULT)"
and then '2' to "Run FreeDOS from CD-ROM (return to command prompt)"
and I get the "C:>" prompt

15. ejected the FreeDOS CD, popped in the CD that was burned in step 12

16. performed a "DIR" command and verified that the ATIFLASH.EXE and EFI5770.rom are present

17. entered the following command to check that my 5770 is found:
ATIFLASH -i <Enter>

adapter  bn  dn  dID   asic     flash        romsize test  bios p/n
====== ==  == ===  ====    ====       =====  === ======
0           01  00 68B8 Juniper  M25P10/c 20000   pass 113-E14802-XV6

18. entered the following command to flash the BIOS:
ATIFLASH -p 0 EFI5770.rom <Enter>

Old SSID: 1482
New SSID: 1482
Old P/N: 113-E14802-XV6
New P/N: 113-E14802-XV6
Old DeviceID: 68B8
New DeviceID: 68B8
Old Product Name: JUNIPER BIOS VCODEv:126
New Product Name: JUNIPER BIOS VCODEv:126
Old BIOS Version: 012.020.000.025.037339
New BIOS Version: 012.020.000.025.037339
Flash type: M25P10/c
20000/20000h bytes programmed
20000/20000h bytes verified

Restart System To Complete VBIOS Update.

19. shutdown the Lenovo PC, took out the 5770; shutdown my Mac Pro and put the 5770 in it

20. connected the PCIe power cable to the 5770, connected both displays and started my Mac Pro

Success !!!
« Last Edit: May 09, 2012, 01:08:36 PM by andychan » Logged
netrix71
Newbie

Offline Offline

Posts: 3


« Reply #334 on: January 07, 2013, 04:33:52 PM »

Hi
i am new to this forum
Please Help Me
is anyone can help me to add EFI string to my rom?
i try all M5770x but not detact display resolution automaticaly

07/27/10 04:57
JUNIPER BIOS UCODEv:128     
113-AC76500-104-PC
0x174B - PC Partner (known as Sapphire)
ATOMBIOSBK-ATI VER012.020.000.035.035211

Attached My Original Rom

* AMD5770ORG.ROM (128 KB - downloaded 701 times.)
Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #335 on: January 07, 2013, 08:12:27 PM »

Hi
i am new to this forum
Please Help Me
is anyone can help me to add EFI string to my rom?
i try all M5770x but not detact display resolution automaticaly

07/27/10 04:57
JUNIPER BIOS UCODEv:128     
113-AC76500-104-PC
0x174B - PC Partner (known as Sapphire)
ATOMBIOSBK-ATI VER012.020.000.035.035211

Attached My Original Rom

Here you go.

Post a link to your card or at least SKU or picture for future readers.

* netrix5770.rom (128 KB - downloaded 685 times.)
Logged
dyttioaoa?
Not Newbie
*
Offline Offline

Posts: 25


« Reply #336 on: January 07, 2013, 10:05:59 PM »

Hi
i am new to this forum
Please Help Me
is anyone can help me to add EFI string to my rom?
i try all M5770x but not detact display resolution automaticaly

07/27/10 04:57
JUNIPER BIOS UCODEv:128     
113-AC76500-104-PC
0x174B - PC Partner (known as Sapphire)
ATOMBIOSBK-ATI VER012.020.000.035.035211

Attached My Original Rom

Here you go.

Post a link to your card or at least SKU or picture for future readers.

If you flash this ROM in DOS, maybe you have to make sure that the filename has 8 chars max. (excluding file type), like "EFIMOD13.ROM".
Logged
netrix71
Newbie

Offline Offline

Posts: 3


« Reply #337 on: January 07, 2013, 11:37:01 PM »

Thanks everyone Who Help Me Out
ill Try Tonight
my video card is link below

http://www.geeks.com/details.asp?invtid=HD5770-PCIE-1024-2-PB

Looks Same As Picture but it has 1xDP 1xHDMI 1x DVI Port
i think it's Acer OEM Or Gateway OEM Video Card

288-5E160-A00AC HD5770 1GB GDDR 5


* HD5770-PCIE-1024-2-PB-unit.jpg (35.52 KB, 500x500 - viewed 1375 times.)
« Last Edit: January 07, 2013, 11:47:09 PM by netrix71 » Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #338 on: January 08, 2013, 07:13:09 PM »

Check if you'll get "ghost" VGA display in System Profiler and Display Preferences. Single DVI 5770 cards often do have it.

BTW, here is thread with ROM making how-to, it used to be sticky, but it no longer is:
   
make your own radeon HD 5770/5870/6870/6850 Mac ROM!
Logged
iAlex
Newbie

Offline Offline

Posts: 3


« Reply #339 on: January 10, 2013, 09:37:43 PM »

can I get a rom for this please: http://www.hisdigital.com/gb/product2-477.shtml?

Cheesy

Thanks
Logged
topaz
Newbie

Offline Offline

Posts: 2


« Reply #340 on: February 04, 2013, 10:08:58 PM »

Hi Guys

can anyone please tell me the latest Mac rom for Ati (dell) 5770 there seems to be lots of wonderful roms posted but am unsure of the latest.

also will the roms load directly from zeus

im using 10.6.8 on a mac pro 2.66 1.1 but plan to upgrade to 10.7.5

any help would be great.  Smiley

Logged
maro_jp
Not Newbie
*
Offline Offline

Posts: 5


« Reply #341 on: June 10, 2013, 11:04:02 AM »

I need help!
I have tried flashing this card myself but didn't work.
If anyone can make a rom, it would be great!

SAPPHIRE HD 5770 1GB GDDR5 PCIE

http://www.sapphiretech.com/presentation/product/?leg=&psn=000101&pid=341&lid=1
ROM ver. 113-E14701-X05

Thanks in advance.

I forgot to attach original ROM.
It's here now!

maro_jp

* MYROM1.ROM (128 KB - downloaded 663 times.)
« Last Edit: June 10, 2013, 01:47:24 PM by maro_jp » Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #342 on: June 10, 2013, 08:17:34 PM »

^Nothing unusual in above BIOS. Use jeanlain's guide to make custom EFI ROM from it. You'll manage.
Logged
maro_jp
Not Newbie
*
Offline Offline

Posts: 5


« Reply #343 on: June 11, 2013, 02:33:25 PM »

Thanks for your advice, blacksheep.
I 've tried agin but no luck.
Maybe I am doing something wrong unnoticed or this particular card is not good for flashing.
I'm attaching rom which I have made in case anyone interested.

maro_jp

* NEWROM.ROM (128 KB - downloaded 655 times.)
Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #344 on: June 11, 2013, 03:14:26 PM »

Use fixrom script and it will work.
Logged
Pages: 1 ... 21 22 [23] 24
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!