netkas.org forum
October 25, 2021, 12:21:31 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: GTX780 ti - Best option for MacPro 5.1 with Mojave???  (Read 7398 times)
overshoot
Not Newbie
*
Offline Offline

Posts: 26


« on: April 10, 2019, 05:03:10 AM »

Hi,

I am about to buy a GTX 780 Ti from macvidcards-europe and I am wondering if that's the best choice for performance/compatibility ratio?!
As I do understand, the GTX 7XX family is natively supported in Mojave because of the drivers being present.
Having a macvidcards will allow me to have the boot screen which is pretty important to me.

The last bit that I am unsure is: are the drivers integrated in Mojave ensuring that this card will be used as its full potential or not?!
Also I've read of potential issues with the PSU not being able to supply enough wattage at some point?!

I am using Premiere Pro with After effects and a powerful but compatible GPU is necessary for real time rendering.

I was thinking of the RX 580 at first, but the lack of boot screen made me look elsewhere.

What do you guys think?
Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 406


« Reply #1 on: April 10, 2019, 10:40:09 AM »

Yes, it's the best option.

Drivers are inside macOS Mojave so it will be always supported.

PSU will handle this GPU without any problems.
Logged
overshoot
Not Newbie
*
Offline Offline

Posts: 26


« Reply #2 on: April 14, 2019, 05:09:54 AM »

Thanks!

I’ll order it ASAP
Logged
goodfidelity
Not Newbie
*
Offline Offline

Posts: 22


« Reply #3 on: August 31, 2021, 07:33:09 PM »

Hi guys!

I have Mac Pro 5.1 and trying to run a GTX 780 with the rom file that is listed on the mac elite wiki website.

Running bootcamp the card boots and runs in windows.

However trying to boot into OSX High Sierra the card will freeze after about 2/3s of the boot bar.

And if i flash the original PC ROM back onto it, it will not start in OSX either.

I was under impression it should run just as fine as GTX680, and i have tried MANY of those cards with no problem.

Is there something obvious that i am missing? Do i need to install the web-drivers or not?

Thanks for any input!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!