netkas.org forum
July 20, 2017, 01:40:02 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 8 9 [10]
  Print  
Author Topic: Apple bones us yet again - hasn't played TB3 by the rules  (Read 43362 times)
ikir
Newbie

Offline Offline

Posts: 6


« Reply #135 on: January 11, 2017, 05:21:37 PM »

Is this with 480?

Can you run System Profiler and show which extensions loaded with "unknown" as provider?
yes 480!
it seems my Thunder3 works just sometimes!

In my extensions there are several unknown as provider like IOThunderboltFamily
/System/Library/Extensions/IOThunderboltFamily.kext
Kext signature validation error code -67061

probably this is the issue right? maybe TB-3 enabler did a mess in my system?

UPDATE: copying kext from a clean install and repairing permission lets them work again
Quote
sudo chmod -R 755 kextfile.kext
sudo chown -R root:wheel kextfile.kext
But one i apply TB enabler i got this:
Quote
Password:
backing up... done
patching... done
clearing kext cache...JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
kext-dev-mode allowing invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext IOThunderboltFamily.kext
symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
JMicronATA.kext has no Info.plist file.
 done


Update a restart indeed my system can't load IOThunderboltFamily.kext
Seems TB-3 enabler didn't work for me
« Last Edit: January 11, 2017, 06:06:36 PM by ikir » Logged
ikir
Newbie

Offline Offline

Posts: 6


« Reply #136 on: January 11, 2017, 05:59:51 PM »

OPPPPSSSSS i was missing LICENSE file! Now it seems to work
Logged
bob
Jr. Member
**
Offline Offline

Posts: 62


MacBook Pro 13" touch bar, 2016. eGPU (Windows).


« Reply #137 on: July 14, 2017, 03:38:09 PM »

Hello!
I've been using Windows on my MBP to get my AKiTiO Thunder3 external GPU to work, and waiting for MacOS High Sierra to show up to get my eGPU to work, installed it and turns out it doesn't work... Been waiting, all betas, this is the 3rd and still nothing. So looking around found that KhaosT & Netkas figured out this patch, downloaded right away, disabled SIP, went back and when trying to apply it, it didn't work, of course; with my excitement I didn't even realize it was for 10.12.x only... I tried to "forceApply" after reading about it, but still nada. So it seems Apple is keeping supporting for all eGPU cases and devices "in jail".
Do you guys know how to "fix this", or have any plans to get this patch to work with MacOS High Sierra too?
Thanks!
Logged
Pages: 1 ... 8 9 [10]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!