netkas.org forum
March 25, 2017, 04:44:38 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 5 6 [7]
  Print  
Author Topic: iMac 2011: Recent GPU for iMac 2011 needed; flashing? (replacing failed 6970m)  (Read 10932 times)
richardhancock
Newbie

Offline Offline

Posts: 41


« Reply #90 on: January 30, 2017, 10:54:24 PM »

Do you think that the EFI & parts of the BIOS from the 8800M GTS would work? (attached) Currently running with the correct display mappings (I think) on the DCB but without any EFI at all, as this seemed to cause issues as it was the one designed for the 27 inch. I have been looking at the Nvidia spec, but not too sure exactly what I need to change with connector table entry where I think the hot plug signals are. I think it should start disabling and then enabling each one by one to find out which is which if i can do this in the same way as with the DCB section?

Any help appreciated !

EDIT: Gone back to the ROM Tried before the flash failed and booting in OS X as well again with EFI Boot on External Screen and unscrambled loading on external screen. Strangely OSX Then three quarter loads and neither screens come on but using remote access the iMac Display is detected as an iMac display however no external at all. I think as Florian suggests its the Hot Plug ID's?

EDIT: Just flashed with the below DCB Table and now OS X Works on the External Screen fully with EFI Loading Screen and when booted:

1F 0F 00 01 34 00 01 00
1F 1F 00 01 10 00 02 00
1F 2F 00 01 30 00 02 00
D6 5F 01 08 20 00 42 0F
92 5F 01 08 20 00 02 00
C6 4F 01 08 10 00 42 0F
82 4F 01 08 10 00 02 00
8F 3F 01 08 30 00 02 00
B6 8F 03 04 10 00 42 0F
72 8F 03 04 10 00 02 00
A6 7F 02 02 10 00 42 0F
62 7F 02 02 10 00 02 00
6F 6F 02 02 10 00 02 00
0F 9F 04 02 00 00 00 00

Going to try and mess with the LVDS soon and get internal as well (Hopefully)

EDIT: Rebooted and now not working again  Huh

* iMac21.rom (154.5 KB - downloaded 14 times.)
« Last Edit: January 31, 2017, 12:12:59 AM by richardhancock » Logged
Pages: 1 ... 5 6 [7]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!