netkas.org forum
March 26, 2017, 03:48:28 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: apple imac 27 ati radeon hd4850m 512mb bios ???  (Read 2303 times)
enzo80
Newbie

Offline Offline

Posts: 9


« on: June 16, 2016, 04:00:39 PM »

Hello,

i search the bios for apple imac 27 ati radeon hd4850m 512mb for download ?
Can anyboady help ?

Best regards
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2077



« Reply #1 on: June 17, 2016, 01:59:32 AM »

Did you look at VGA Database at 3D Guru?

I think many iMac ones are there.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
enzo80
Newbie

Offline Offline

Posts: 9


« Reply #2 on: June 17, 2016, 12:37:51 PM »

I cannot find any vga bios roms on guru3d ?
Can you help with a link ?
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 798



« Reply #3 on: June 17, 2016, 01:38:14 PM »

Probably it's tpu, not guru3d - http://www.techpowerup.com/vgabios/
Logged
blacksheep
Sr. Member
****
Offline Offline

Posts: 337


« Reply #4 on: June 19, 2016, 12:41:47 AM »

iMac Graphics Firmware update
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2077



« Reply #5 on: June 19, 2016, 06:18:30 AM »

If you click on Netkas' link, then choose "Apple" as manufacturer,BANG, there is your rom.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
enzo80
Newbie

Offline Offline

Posts: 9


« Reply #6 on: June 20, 2016, 09:13:39 AM »

Thank you for the link.
Today i flashed the ati radeon hd4850m 512mb mxm card with the apple ati radeon 4850 bios from techpowerup.
But the internal screen does not show the white efi start screen on booting up the imac.
Also there is no efi white boot screen on external monitor connected via display port.
Furthermore whan os-x is booted there is a normal Screen with internal and external display.
I think there is something wrong with the bios or the efi partition is not there Huh
Can anybody with an imac 27 and ati radeon hd4850m installed be so kind and make a bios dump of his card with atiflash -s 0 hd4850.rom and send it via email.
I will donate him with 10€ via paypal.

best regards
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2077



« Reply #7 on: June 20, 2016, 11:30:26 AM »

compare device ids.

And it is super duper easy to look for the EFI

Open rom in a hexeditor and have a look.

BIOS should be forst, start with 55AA and then next byte is length of BIOS in 512 k blocks.

Go to that address and you should see EFI section, it too will start with 55AA.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
enzo80
Newbie

Offline Offline

Posts: 9


« Reply #8 on: June 20, 2016, 11:53:47 AM »

The point is that a friend gave me that card, because he flashed it with a wrong bios.
The card was dead at all.
The card was fully functional before the wrong flash.
I flashed it with the bios from techpowerup.
It has no efi boot screen.
But functions normally when os-x is booted over internal and external display.
I have not the original bios to compare it.
It will be so kind, when anybody can do a bios dump from his ati radeon 4850 in an imac 27 from 2009.

Best regards
Logged
enzo80
Newbie

Offline Offline

Posts: 9


« Reply #9 on: June 20, 2016, 01:53:44 PM »

I have flashed the ati radeon hd 4850 mxm with the attached rom from techpowerup.
There is something wrong with this bios rom, because the card is recogniced as radeon hd4800 in os-x.
And if you look further in system configuration monitor/video card there is no efi version displayed.
Can anybody help Huh

* Apple.HD4850.512.090828.rom (62 KB - downloaded 80 times.)
Logged
neon3400
Newbie

Offline Offline

Posts: 1


« Reply #10 on: January 19, 2017, 02:42:55 AM »

hey


i have a working rom dump from a original apple ati HD4850m 512mb mxm3 card

see the attach

* working dump.BIN (128 KB - downloaded 24 times.)
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!