netkas.org forum
August 19, 2019, 10:33:21 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 45 46 [47] 48 49 ... 60
  Print  
Author Topic: Booting the 64-bit kernel on the 2006/2007 Mac Pro  (Read 1208388 times)
chromafile
Jr. Member
**
Offline Offline

Posts: 88


« Reply #690 on: January 11, 2013, 07:02:04 AM »

I'm not sure alternative serial numbers are working for anyone. I am in the same situation as yourself.
I think, you are right. Apple's subtle way of discouragement. This was working fine for many months. It's a server side change, me thinks...

Seems like it's working if you use Clover EFI Bootloader.
http://bit.ly/13iJVGl
Does the Clover loader support 12GB RAM? Most of the previous solutions crashed above 8GB.

No idea 'cause I haven't tried Clover yet.
But you seem to confuse the patched boot.efi and Clover EFI bootloader.
Doesn't Clover do an EFI boot?

The EFI boot is for PC UEFI boards, not for a real Mac.
I just tried Clover and the EFI boot isn't working. So, I used a legacy boot method, instead.
It worked but sound & extra SATA ports don't work even though I used DSDT.aml.
Clover is a bit complicated for Mac Pro:( 
Logged
armdn
Full Member
***
Offline Offline

Posts: 149


« Reply #691 on: January 19, 2013, 06:43:43 PM »

How did you do this? Can you give an instruction?
Logged
nullbreached
Not Newbie
*
Offline Offline

Posts: 8


« Reply #692 on: January 19, 2013, 07:22:52 PM »

I don't believe Clover works on "real" Macs at this point. There is discussion about adding a feature to Chameleon for this iMesage issue for "real" Macs but it might be dying on the vine:

http://forge.voodooprojects.org/p/chameleon/issues/309/#ic2397
Quote from: nullbreached link=topic=1123.msg18461#msg18461 date=1357661853
Seems like it's working if you use Clover EFI Bootloader.
http://bit.ly/13iJVGl
Has anybody seen descriptions of how to use Clover on a Mac Pro?
Logged
chromafile
Jr. Member
**
Offline Offline

Posts: 88


« Reply #693 on: January 19, 2013, 09:35:42 PM »

How did you do this? Can you give an instruction?

I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...

I have GPT Mountain Lion SSD and MBR BOOT & Lion SSD, so the instruction is based on this setting.
You should modify config.plist for your configuration. Mine is Xeon x5355 + Radeon HD5770 (Apple)
If your Apple ID password is less than 8 characters, login for iMessage might fail. So change password to 8+ characters.
I use the real serial number of MacPro3,1. Not sure whether faked one works or not.
Please don't ask me the real serial number. It belongs to my friend's MacPro3,1 and I can't share it with you.
 
1. Boot into Lion and format BOOT partition (HFS+).
2. Download my config.plist and Clover EFI bootloader from http://bit.ly/We0ZrR
3. Install Clover into BOOT partition (Standard Installation).
4. Open config.plist with Xcode or your favorite text editor.
5. Change DefaultBootVolume, SerialNumber and MLB. MLB is your serial number + 6 characters (total 17 characters).
6. Replace config.plist at /Volumes/BOOT/EFI
7. open Terminal and run "sudo bless --folder=/Volumes/BOOT/ --file=/Volumes/BOOT/EFI/BOOT/CLOVERX64.efi --setBoot --legacy", then reboot.
8. When Clover Menu appears, Mountain Lion drive should be selected, then enter.  
9. Launch Messages and enter your Apple ID to login. You might wanna open Messages' preferences to check if you successfully logged in.
10. If you successfully logged in iMessage, boot into Lion. Format BOOT partition and install Chameleon and Extra.
11. Open Terminal and run "sudo bless --folder /Volumes/BOOT --file /Volumes/BOOT/boot --setBoot --legacy", then reboot.
12. Launch Messages and you should stay logged-in.

* config.plist (2.38 KB - downloaded 583 times.)
« Last Edit: January 19, 2013, 10:13:10 PM by chromafile » Logged
armdn
Full Member
***
Offline Offline

Posts: 149


« Reply #694 on: January 20, 2013, 08:46:32 AM »

Great THANKS! Will try this!

About Serial, i don't mind, will use my own original from MacPro2,1.
« Last Edit: January 20, 2013, 10:09:46 AM by armdn » Logged
Eckhart
Not Newbie
*
Offline Offline

Posts: 9


« Reply #695 on: January 20, 2013, 08:03:48 PM »

Hello, chromafile.

Where is your config.plist?

And thanks for the instructions!
Logged

MacPro 2,1, Dual Quad-Core Intel Xeon 3GHz, 16GB RAM, SSD, ATI Radeon HD 5870
chromafile
Jr. Member
**
Offline Offline

Posts: 88


« Reply #696 on: January 20, 2013, 08:39:03 PM »

Hello, chromafile.

Where is your config.plist?

And thanks for the instructions!

The attachment of my post.
Logged
Eckhart
Not Newbie
*
Offline Offline

Posts: 9


« Reply #697 on: January 20, 2013, 08:54:25 PM »

Sorry. I read your instructions without being logged.

Thanks a lot!
Logged

MacPro 2,1, Dual Quad-Core Intel Xeon 3GHz, 16GB RAM, SSD, ATI Radeon HD 5870
orsodimare
Not Newbie
*
Offline Offline

Posts: 11


« Reply #698 on: January 21, 2013, 12:16:31 PM »


I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...


Thanks for the info: I will try it on my MP next week.
Why, once installed Clover and enabled iMessage, you suggest to roll-back to Chameleon ??
Logged
chromafile
Jr. Member
**
Offline Offline

Posts: 88


« Reply #699 on: January 21, 2013, 04:30:59 PM »


I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...


Thanks for the info: I will try it on my MP next week.
Why, once installed Clover and enabled iMessage, you suggest to roll-back to Chameleon ??


Because, with Clover, I can't get sound working and SATA doesn't work properly, as a result, extra SATA doesn't work at all. I just don't have time to figure them out right now.
Good news is, I read Chameleon devs are working on iMessage fix. When it's out, we don't have to use Clover just for iMessage.
Logged
HaraldSt
Full Member
***
Offline Offline

Posts: 102


« Reply #700 on: January 22, 2013, 01:04:50 AM »


I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...


Thanks for the info: I will try it on my MP next week.
Why, once installed Clover and enabled iMessage, you suggest to roll-back to Chameleon ??

Because, with Clover, I can't get sound working and SATA doesn't work properly, as a result, extra SATA doesn't work at all. I just don't have time to figure them out right now.
Good news is, I read Chameleon devs are working on iMessage fix. When it's out, we don't have to use Clover just for iMessage.

Alas, not working for me. After the Clover Boot Screen, I get a white screen with the no go sign. I am running 10.8.3. Back to Chameleon...
« Last Edit: January 22, 2013, 04:22:01 AM by HaraldSt » Logged
chromafile
Jr. Member
**
Offline Offline

Posts: 88


« Reply #701 on: January 22, 2013, 08:22:28 AM »


I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...


Thanks for the info: I will try it on my MP next week.
Why, once installed Clover and enabled iMessage, you suggest to roll-back to Chameleon ??

Because, with Clover, I can't get sound working and SATA doesn't work properly, as a result, extra SATA doesn't work at all. I just don't have time to figure them out right now.
Good news is, I read Chameleon devs are working on iMessage fix. When it's out, we don't have to use Clover just for iMessage.

Alas, not working for me. After the Clover Boot Screen, I get a white screen with the no go sign. I am running 10.8.3. Back to Chameleon...


Forget about the Clover solution. Chameleon now supports iMessage.
Download FileNVRAM.dylib and copy it to /Extra/modules/
Use Custom Installation of Chameleon-2.2svn-r2171 to install FileNVRAM
reboot and try iMessage.

Chameleon-2.2svn-r2171.pkg is here
http://www.sendspace.com/file/xk7fkj
http://www.sendspace.com/file/nfne6i
« Last Edit: January 22, 2013, 09:09:43 PM by chromafile » Logged
firecast
Newbie

Offline Offline

Posts: 2


« Reply #702 on: January 22, 2013, 09:04:54 AM »

Thanks, chromafile!
Compiling Chameleon r2170 and adding FileNVRAM.dylib enabled iMessage on my MacPro2,1 10.8.2. :-)
Logged
cloudgoblin
Newbie

Offline Offline

Posts: 1


« Reply #703 on: January 22, 2013, 01:17:37 PM »

i'm using 2006 2007 imac intel core 2 duo just installed a linux mint 64 bit on the machine using GRUB for dual boot works fine and much smoother than osx SL which runs 32 bit thanks to the 32 bit efi .

grub menu allows me to boot osx 64 bits so i was curious to see how that would run .
i run in the same problems as mac pro users
namely sound not working     Sascha_77 patch works fine for me
full HD not enabled  i didn't find anything relevant for me not beeing anything near an expert
but fidling around i'm under the impression that the xnu statements in grub.cfg ,originating from /etc/grub.d/30_os-prober, can't read properly /system/library/extensions/bundled files kext
has anyone got an idea about that?
I believe that if i got the proper xnu statements both the sound and display problems would be solved without complicated (for me) patches
The 32 bit osx boot from grub menu has in the same problem not suprisingly since xnu statements are the same
extracting kexts from the bundlles into the /system/library/extensions led to kernel panic crashes booting from grubmenu which means they get read that way by grub xnu statements ,
the standart osx booting works just fine though not troubled a bit by unusual folder content so my question is what is the conventional osx bootloader calling that allows it to read the proper kext files that the grub xnu statements does not
here is the the grub shell call i have

  menuentry "Mac OS X (64-bit) (on /dev/sda2)" --class osx --class darwin --class os {
   insmod part_gpt
   insmod hfsplus
   set root='(hd0,gpt2)'
   search --no-floppy --fs-uuid --set=root 22ee0dd4e18491a5
        load_video
        set do_resume=0
        if [ /var/vm/sleepimage -nt10 / ]; then
           if xnu_resume /var/vm/sleepimage; then
             set do_resume=1
           fi
        fi
        if [ $do_resume = 0 ]; then
           xnu_uuid 22ee0dd4e18491a5 uuid
           if [ -f /Extra/DSDT.aml ]; then
              acpi -e /Extra/DSDT.aml
           fi
           xnu_kernel64 /mach_kernel boot-uuid=${uuid} rd=*uuid
           if [ /System/Library/Extensions.mkext -nt /System/Library/Extensions ]; then
              xnu_mkext /System/Library/Extensions.mkext
           else
              xnu_kextdir /System/Library/Extensions
           fi
           if [ -f /Extra/Extensions.mkext ]; then
              xnu_mkext /Extra/Extensions.mkext
           fi

I could probably build a /Extra directory but i hven't a clue about dooing this
I havn't found anything about xnu statements that's relevant
Logged
HaraldSt
Full Member
***
Offline Offline

Posts: 102


« Reply #704 on: January 23, 2013, 12:22:50 AM »


I gathered some info from insanelymac.com & tonymacx86.com and iMessage is finally working with Chameleon.
You have to use Clover to enable iMessage, then go back to Chameleon. So here we go...


Thanks for the info: I will try it on my MP next week.
Why, once installed Clover and enabled iMessage, you suggest to roll-back to Chameleon ??

Because, with Clover, I can't get sound working and SATA doesn't work properly, as a result, extra SATA doesn't work at all. I just don't have time to figure them out right now.
Good news is, I read Chameleon devs are working on iMessage fix. When it's out, we don't have to use Clover just for iMessage.
Forget about the Clover solution. Chameleon now supports iMessage.
Use Custom Installation of Chameleon-2.2svn-r2171 to install FileNVRAM
reboot and try iMessage.

Chameleon-2.2svn-r2171.pkg is here
http://www.sendspace.com/file/nfne6i
Worked on first try, brilliant.

Note: this also fixes the DVD Player crash!!!

Excellent work!
Logged
Pages: 1 ... 45 46 [47] 48 49 ... 60
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!