netkas.org forum
March 28, 2017, 05:19:04 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: AppleIntelCPU, AppleACPI, etc...  (Read 25324 times)
frantisheq
Jr. Member
**
Offline Offline

Posts: 59



« Reply #15 on: January 18, 2008, 07:19:08 PM »

Hi
since my graphic string and my sound string still don't work: What exactly is it all about those configuration-tables. I can see in your screenshots that you have several tables in ioreg? I can only see two (the last two in frantisheq's screenshot starting with EB9D) here...
Thanks for any help and clarifying  Smiley
first for graphics, second for network (TM fix) and the third for sound
Logged
stellarola
Newbie

Offline Offline

Posts: 14


« Reply #16 on: January 19, 2008, 07:57:21 AM »

It'd be really great to get AppleIntelCPU working at least. I was told that when using the 10.5.2 update the system will (kernel panic) freeze during the update because it tries to load this kext. I've installed an older version of the 10.5.2 adc update and it did freeze my system mid install. I was under the assumption that it checked for dsmos and said F U. Which I now know this isn't the case.

So anyways... it'd be peachy to get AppleIntelCPU to load properly.

Thanks for tuning in,

-Stell
Logged
eberts
Newbie

Offline Offline

Posts: 14


« Reply #17 on: January 19, 2008, 02:19:51 PM »

Hi
since my graphic string and my sound string still don't work: What exactly is it all about those configuration-tables. I can see in your screenshots that you have several tables in ioreg? I can only see two (the last two in frantisheq's screenshot starting with EB9D) here...
Thanks for any help and clarifying  Smiley
first for graphics, second for network (TM fix) and the third for sound

Ok, solved! I got it working, finally. Problem was, that somehow my com.apple.Boot.plist was sort of broken (?): Property List Editor couldn't open it. I used to edit it in terminal with nano before. So obviouly, I messed it. Now both graphics (my 7300GT) and sound (ALC882) work perfectly without nvinject and ALCinject. Thanks you all for your help and thanks for the great tool!  Grin
One more question related to this topic: You mentioned a HPET device. I dont' find it in IORegistryExpl. Why? My board should have it (ICH7).
Cheers
Logged
indraganzo
Newbie

Offline Offline

Posts: 24


« Reply #18 on: January 20, 2008, 08:22:49 PM »

 I also can not find a hpet node anywhere in my device tree my board is also ich 7
 I don't know what to look for???
Logged

Mobo: MSI 975x Platinum PU edition CPU: Intel® Core™2 Quad 6600 @ 2.89 Ghz GFX Card: Sparkle NVidia 7600 GS 256mb Memory: 4 x 1gb DDR2 667mhz HD: Seagate Baracuda 7200 80GB Os: Leopard 10.5.5 vanilla Kexts ,Sleep and Shutdown ok
GLKA
Newbie

Offline Offline

Posts: 3


« Reply #19 on: April 08, 2008, 05:41:58 AM »

Anybody try to make HPET-string, for use  AppleIntelCPUPowermanagement.kext ?
Logged
westwaerts
Newbie

Offline Offline

Posts: 17


« Reply #20 on: April 11, 2008, 05:18:39 PM »

Still wondering, but i stepped over same problem at the same time.
bob, your unable get uuid did help me,

but i found out that at the very high level of the ioreg there is an aliases entry,
on the other hand, at the system messages at startup there are on real macs prelinked modules or so, what we dont have.

so i think that real hardcoded efi has nearly a complete system profil, thats loaded at startup. if we can get that in the efi string method, we are nearer on mac than they would like to have us.

on third note, bios uses tables for cpus, thats why a core2 still has 4cores in the registry and only 2 are active



« Last Edit: April 11, 2008, 05:21:14 PM by westwaerts » Logged
GLKA
Newbie

Offline Offline

Posts: 3


« Reply #21 on: April 11, 2008, 07:02:08 PM »

In Tiger,  AppleIntelCPUPowermanagement.kext  loaded and worked.


* HPET Tiger.jpg (69.21 KB, 768x562 - viewed 270 times.)
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!