netkas.org forum
January 22, 2022, 01:37:21 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 10 11 [12] 13 14 ... 30
  Print  
Author Topic: 6870 efi rom test  (Read 663445 times)
Athirne
Not Newbie
*
Offline Offline

Posts: 6


« Reply #165 on: August 28, 2011, 12:28:23 AM »

Hey guys, here is an application you can test&try for creating hybrid rom.



Just select where you wan to get bios rom from - card or file

then press - select bios rom to confirm selection or select bios rom file

then select efi rom and press "create rom" to save your created rom

if some errors occurs, you will see it in error log.

Link to app - http://rghost.ru/19375601

efi roms you can get here - http://forum.netkas.org/index.php/topic,1085.msg6517.html#msg6517

Dumping in only possible if you use native drivers, dont use it with aty_init, risking to get bad rom.

Also, don't use with card which has MCuC section, like radeons 4xxx

Is this still V7 or is there a new EFI string included?
Logged
m0squito
Not Newbie
*
Offline Offline

Posts: 7


« Reply #166 on: August 28, 2011, 11:45:54 AM »

Ah, thanks for clearing that out for me. =)
I wasn't shure if 2,1 meant 64bit or 32bit Efi actually.

I'll have a look at a 57xx the I guess, the fan died in my 4980, so it's time for a new one. Are there any know cards that there are issues with by the way, do they all seem to be flash'able?

best,
m0


1,1 and 2,1 = 32bit efi

3,1 and 4,1 and 5,1 = 64bit efi


answer= no, not until UBC firmware is released (aka 6870 from apple)
Logged
Cindori
Full Member
***
Offline Offline

Posts: 237



WWW
« Reply #167 on: August 28, 2011, 12:15:34 PM »

you can use 6870 with macpro 1,1 2,1, just no boot screen
Logged

http://groths.org
Tools and news about Mac graphics and Hackintosh
machacks
Not Newbie
*
Offline Offline

Posts: 7


« Reply #168 on: August 28, 2011, 12:58:46 PM »

I have amd-radeon-hd-6950,  i like to get working in my Hackintosh.  I have Mac Pro Quad-Core x 2 Early 2009 with Quadro 4000 for Mac edition.  Any way to get this working?
Logged
Cindori
Full Member
***
Offline Offline

Posts: 237



WWW
« Reply #169 on: August 28, 2011, 01:06:44 PM »

I have amd-radeon-hd-6950,  i like to get working in my Hackintosh.  I have Mac Pro Quad-Core x 2 Early 2009 with Quadro 4000 for Mac edition.  Any way to get this working?

not yet
Logged

http://groths.org
Tools and news about Mac graphics and Hackintosh
Ibrin
Newbie

Offline Offline

Posts: 1


« Reply #170 on: August 28, 2011, 10:34:59 PM »

I'm really hoping that we get some luck with the 6950, when that gets released by Apple.  I think that will be about the max for a Mac Pro 1,1.  The 6950 only requires 2x6-pin power, and has 2GB of VRAM.  It also has the Dual BIOS, which should make flashing risk-free.

You can see details on the BIOS and such here:

http://widescreengamingforum.com/article/amd-radeon-6970-6950-review

I run the WSGF, and in that article I actually theorized that the 6900 series would be popular with Mac users due to the dual BIOS.  If anyone needs any ROMs dumped, please let me know (and point me to a tutorial on how to do it).  I get reference cards from AMD for testing/benchmarking, and I have every reference card in the 6000 series sitting in boxes in my office, as well as the 5000-series.  I will also be getting 7000-series when they are available.
Logged
ShinOkazaki
Newbie

Offline Offline

Posts: 4


« Reply #171 on: August 29, 2011, 08:58:45 AM »

Cindori's new flasher WORKS ON 5870 !!!

It worked for me in Lion, but not SL.

2nd Piece of good news:

Netkas new app sees 5870...should be able to make 5870 ROMs too.

Will test shortly.

UPDATE : Flasher works on 5870, but only using certain ROMs.

Somebody needs to figure out.

Wll use Sapuakari rom pretty easily, but not genuine one I made using Netkas app.

Still looking very good for easier 5870 flashing.
Does this mean we'll finally get a bootscreen even on 5870?
Logged
Bolle
Full Member
***
Offline Offline

Posts: 107


« Reply #172 on: August 29, 2011, 10:58:46 AM »

No.
Logged
All Inclusive Package
Newbie

Offline Offline

Posts: 1


« Reply #173 on: August 29, 2011, 01:32:05 PM »

I have the chance to purchase a XFX HD 6870 for £70.00 and was wondering if this can be safely flashed to work in my 3,1 (2008) MacPro. Are all the bits and bobs necessary to carry out the procedure available on this site and how safe is it? Is it reversible if I can't get it to work? Do I need to find a PC to flash the GPU or can it be done in the MacPro?

Really sorry, complete idiot here who needs to be held by the hand.
Logged
neo_fox33
Newbie

Offline Offline

Posts: 2


« Reply #174 on: August 30, 2011, 07:43:21 PM »

hi, sorry doesn´t works for my card. i have 1 HDMI , 2 DVI ports and only 1 DSP is only difference.

how i can do to my card works fine?
sorry by my english i use a online translator.


Logged
Weust
Not Newbie
*
Offline Offline

Posts: 24


« Reply #175 on: August 30, 2011, 09:44:04 PM »

I tried the display port cable on sunday, but no visual at all.
Need to test the other cables combo's still.
So far only DVI for me.
« Last Edit: August 31, 2011, 01:06:05 PM by Weust » Logged
neohc
Newbie

Offline Offline

Posts: 3


« Reply #176 on: August 31, 2011, 11:43:34 AM »

Ok got my XFX 6870 (ZDFC) in and flashed it today under Windows. Used the FirmwareUtility posted by Cindori a page back then under windows used the ATI flash utility to flash the resulting image. Grabed the firmware using Z-GPU and renamed the resulting ROM from .bin to .rom like ya do. I will be updating the post tomorrow with more details, have to wake up early and dont have the energy to play with what ports/devices work, besides my minidp to DP cable comes tomorrow.

Mac Pro 3,1
XFX HD 6870 1 GB (HD-687A-ZDFC)


Hi, sorry for this noob post, but I've been racking my brain literally all night (it's now 5:30 AM)...
My 8800GT went bad, and seeing as other people had good success with the XFX Radeon 6870 (ZDFC with the dual fan), I ordered one and got it yesterday.

I don't have bootcamp, but luckily I can use the computer via screen sharing.
I had to download the ROM from Athirne (who has the same mac pro 3,1 and the xfx card).
I have tried the zeus tool but it doesn't work.
I tried to take the PC ROM, then convert it using the FirmwareUtility, then flashing it using zeus, but it didn't work
I tried RomCreator, but it requires Lion (I was on leopard)

So then I decided I would upgrade to SL and try again... the SL reinstall drive from my macbook air wouldn't install... neither would my retail DVD...
I decide maybe I can do an install if I put in the old 8800GT and hope it doesn't completely crap out on me while trying to install...

...except that the 6870 was stuck due to the clip that's supposed to secure it in place... I ended up having to disassemble my mac pro short of taking out the logic board, but it took forever finding disassembly instructions for the 2008...
Finally I get the thing out, plop the 8800GT but... no success... mac freezes shortly after selecting SL install discs.

Then I remembered I had an old laptop hard drive with snow leopard on it thinking I'd try the RomCreator... only to find that the romcreator only works in lion

Summary: I pulled an all nighter trying to get this working, but have failed so far. I think I've tried everything I can to get this 6870 flashed, but I keep running into dead ends. I'm guessing I'm missing something stupid here, so I'm asking for your help. Any ideas/suggestions? Thanks!
Logged
optikshell
Not Newbie
*
Offline Offline

Posts: 26


« Reply #177 on: August 31, 2011, 05:19:19 PM »

Ok - I'm a bit stuck. I recently had success with an XFX 6770 in my 3,1 Mac Pro running 10.6.8.

I just got a Sapphire Vapor-X 6870, and can't seem to get it working. I dumped the rom via FreeDOS/atiflash, booted into OSX and created the new rom with the terminal commands listed in jeanlain's post, followed by the fixrom.py bit. Rebooted to FreeDOS and used atiflash to flash the new rom. Rebooted into OSX...

Black screen, but I can log in via screen sharing. I updated the ATI...6000.kext file with the device id for my card, rebooted, and now OSX won't start. I verified that the kext is causing it to hang by removing the 6870, reinstalling my old 8800, removing my device id from the kext, shutting down, reinstalling 6870... back to a black screen (neither DVI port working), but able to remotely connect via screen sharing.

I can't seem to find clear steps or instructions for drivers/kexts and the Sapphire Vapor-X 6870. I'm probably going to start over with the original bios rom dump. Should I try one of the new utilities for creating roms for the 6870s? Which drivers / kexts do I need... and are any modifications required?

I'm kinda stuck...  Huh Thanks for all the help everyone.
Logged

Mac Pro 2008 3,1 - 10.7.1

original: 8800GT
current: Sapphire Vapor-X 6870, working great.
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #178 on: August 31, 2011, 07:16:55 PM »


Hi, sorry for this noob post, but I've been racking my brain literally all night (it's now 5:30 AM)...
My 8800GT went bad, and seeing as other people had good success with the XFX Radeon 6870 (ZDFC with the dual fan), I ordered one and got it yesterday.

I don't have bootcamp, but luckily I can use the computer via screen sharing.
I had to download the ROM from Athirne (who has the same mac pro 3,1 and the xfx card).
I have tried the zeus tool but it doesn't work.
I tried to take the PC ROM, then convert it using the FirmwareUtility, then flashing it using zeus, but it didn't work
I tried RomCreator, but it requires Lion (I was on leopard)

So then I decided I would upgrade to SL and try again... the SL reinstall drive from my macbook air wouldn't install... neither would my retail DVD...
I decide maybe I can do an install if I put in the old 8800GT and hope it doesn't completely crap out on me while trying to install...

...except that the 6870 was stuck due to the clip that's supposed to secure it in place... I ended up having to disassemble my mac pro short of taking out the logic board, but it took forever finding disassembly instructions for the 2008...
Finally I get the thing out, plop the 8800GT but... no success... mac freezes shortly after selecting SL install discs.

Then I remembered I had an old laptop hard drive with snow leopard on it thinking I'd try the RomCreator... only to find that the romcreator only works in lion

Summary: I pulled an all nighter trying to get this working, but have failed so far. I think I've tried everything I can to get this 6870 flashed, but I keep running into dead ends. I'm guessing I'm missing something stupid here, so I'm asking for your help. Any ideas/suggestions? Thanks!


1. Return 6870
2. Go to Apple Store
3. Buy 5770 or 5870
4. Spend 6 or 8 hours installing it and call it a day

Dude, you have seriously managed to make a 1 hr task into a 12 hour task.

You are clearly one of those people who MAKE things difficult for yourself.

WHy all this bootcamp/screensharing stuff?

6870 has worked OOTB for months. Since 10.6.6 MacBook kexts came out, (in April) in either regular 10.6.8 or Lion. If you could not get an image by just putting it in your machine, you should have given up then.

You couldn't figure out how to hold a little plastic clip up while pulling card out of machine so you spent HOURS completely disassembling entire computer?

YOU ARE NOT A HACKER !!!

Go do whatever it is you are good at, and let someone else do the computer stuff for you. This just isn't your thing.
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
Cindori
Full Member
***
Offline Offline

Posts: 237



WWW
« Reply #179 on: August 31, 2011, 07:54:22 PM »



I don't have bootcamp, but luckily I can use the computer via screen sharing.
I had to download the ROM from Athirne (who has the same mac pro 3,1 and the xfx card).
I have tried the zeus tool but it doesn't work.
I tried to take the PC ROM, then convert it using the FirmwareUtility, then flashing it using zeus, but it didn't work
I tried RomCreator, but it requires Lion (I was on leopard)

So then I decided I would upgrade to SL and try again... the SL reinstall drive from my macbook air wouldn't install... neither would my retail DVD...
I decide maybe I can do an install if I put in the old 8800GT and hope it doesn't completely crap out on me while trying to install...
. I think I've tried everything I can to get this 6870 flashed, but I keep running into dead ends. I'm guessing I'm missing something stupid here, so I'm asking for your help. Any ideas/suggestions? Thanks!

1. 6870 only works in Snow Leopard 10.6.8 (maybe driver pkg needed, dont remember) or in Lion (without package needed).
2. Zeus can only flash 6870 series in Lion (or maybe Snow Leopard and Lion selected in combo box, havent tried)


If you seriously tried to use 6870 in Leopard (10.5) you can't have researched this for more then 1 hour...
« Last Edit: August 31, 2011, 07:56:09 PM by Cindori » Logged

http://groths.org
Tools and news about Mac graphics and Hackintosh
Pages: 1 ... 10 11 [12] 13 14 ... 30
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!