netkas.org forum
September 24, 2020, 04:43:48 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 17 18 [19] 20 21 ... 24
  Print  
Author Topic: Radeon Port Mapping  (Read 402246 times)
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #270 on: January 19, 2016, 01:38:13 PM »

Yep that's usual behavior even on OEM Apple cards, the boot screen will only appear on one port if multiple displays are connected. The order is specified in the EFI.
Glad it works for you! Smiley
Logged
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #271 on: January 29, 2016, 10:52:07 PM »

SMIKX I am sort of glad you would not post or send me your efi roms at the time but I did think that was just not right! We're Australian after all!  Smiley
BUT, once I found the time (very hard with 3 kids and Christmas holidays) and get the courage to spend the 30 minutes to stitch the rom and flash the bios it was indeed easy. Thanks to the fantastic information here I now have a good efi rom and the original tucked away for my 5870.

I will now have to try to see how to port map as I only have boot screen on DVI/VGA adaptor.

TC


I side with Rominator in that it took me ages to muster up the courage to go through sewing efi & Fl0r!an's roms together.

Doing it yourself, engaging in the 'learning process' can't be a negative thing.

Fl0r!an insisted that it was not hard, encouraged me to try and in fact it wasn't and by doing it by myself instead of waiting for a rom to appear here I have enriched my Mac hacking abilities and understanding of 'How Mac things work '.

I now have EFI roms for my HD  5770's and HD 5870's ( 2 each ). Now that I know how easy the sewing process actually is I will not post them here as the EFI parts are already here in these pages.

Happy, safe and prosperous New Year too all.

Kyoto, JAPAN.



* Screen Shot 2016-01-30.jpg (178.84 KB, 1635x926 - viewed 1191 times.)
« Last Edit: January 29, 2016, 11:34:17 PM by Techchallenged » Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 405


« Reply #272 on: January 30, 2016, 12:00:42 AM »

Florian - can you check this BIOS from ASUS non-reference R9 280X ?

When used with Hamachi only upper DVI works with bootscreen, when used with Futomaki upper DVI and HDMI works.

It's the fastest R9 280X I've ever seen.

* Tahiti.rom (128 KB - downloaded 571 times.)
Logged
Fl0r!an
Sr. Member
****
Offline Offline

Posts: 351


« Reply #273 on: January 30, 2016, 05:42:28 PM »

Your Asus card:

Code:
enc  / tx  / HP  / SenseID
0x21 / 0x3 / 0x6 / 0x4   (DP)
0x11 / 0x2 / 0x1 / 0x3   (HDMI)
0x12 / 0x4 / 0x4 / 0x2   (DVII)
0x10 / 0x0 / 0x3 / 0x6   (DVID)

Hamachi:
Code:
00040000040300000001010112040501
00040000040300000001020122050402
04000000140200000001030000000306
00080000040200000001040011020104
=> DP dead, HDMI sense ID mismatch (=> dead), DVI-I sense ID & HP ID mismatch (=> dead), DVI-D match

Futomaki:
Code:
00040000040300000001010112040401
00040000040300000001020122050502
04000000140200000001030000000606
00080000040200000001040011020103
=> DP dead, HDMI match, DVI-I sense ID mismatch (=> dead), DVI-D HP ID mismatch (hotplugging might be broken, should work beside that)
Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 405


« Reply #274 on: January 31, 2016, 12:33:53 PM »

Your Asus card:

Code:
enc  / tx  / HP  / SenseID
0x21 / 0x3 / 0x6 / 0x4   (DP)
0x11 / 0x2 / 0x1 / 0x3   (HDMI)
0x12 / 0x4 / 0x4 / 0x2   (DVII)
0x10 / 0x0 / 0x3 / 0x6   (DVID)

Hamachi:
Code:
00040000040300000001010112040501
00040000040300000001020122050402
04000000140200000001030000000306
00080000040200000001040011020104
=> DP dead, HDMI sense ID mismatch (=> dead), DVI-I sense ID & HP ID mismatch (=> dead), DVI-D match

Futomaki:
Code:
00040000040300000001010112040401
00040000040300000001020122050502
04000000140200000001030000000606
00080000040200000001040011020103
=> DP dead, HDMI match, DVI-I sense ID mismatch (=> dead), DVI-D HP ID mismatch (hotplugging might be broken, should work beside that)

Yeah - that's what I've thought Wink
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 92



« Reply #275 on: February 07, 2016, 04:12:42 AM »



Yes, it initially feels frightening but ends up being highly educational .. no pain, no gain.

Nothing quite matches seeing the Apple pop up on the monitor.

 . .. . .  AND  > > > I finally got hold of a MAc Pro 4,1 ! Yeah!

Well worth the effort. Thanks to Fl0r!an.

I'm off to OZ ( Australia ) in April ( Brisbane ) . . gonna amble down to the Brekky Creek Hotel for some yummy Barramundi Mate !

SMIKX I am sort of glad you would not post or send me your efi roms at the time but I did think that was just not right! We're Australian after all!  Smiley
BUT, once I found the time (very hard with 3 kids and Christmas holidays) and get the courage to spend the 30 minutes to stitch the rom and flash the bios it was indeed easy. Thanks to the fantastic information here I now have a good efi rom and the original tucked away for my 5870.

I will now have to try to see how to port map as I only have boot screen on DVI/VGA adaptor.

TC


I side with Rominator in that it took me ages to muster up the courage to go through sewing efi & Fl0r!an's roms together.

Doing it yourself, engaging in the 'learning process' can't be a negative thing.

Fl0r!an insisted that it was not hard, encouraged me to try and in fact it wasn't and by doing it by myself instead of waiting for a rom to appear here I have enriched my Mac hacking abilities and understanding of 'How Mac things work '.

I now have EFI roms for my HD  5770's and HD 5870's ( 2 each ). Now that I know how easy the sewing process actually is I will not post them here as the EFI parts are already here in these pages.

Happy, safe and prosperous New Year too all.

Kyoto, JAPAN.



This is a Barramundi.


* Barramundi.jpg (27.79 KB, 500x281 - viewed 1127 times.)
Logged

Mac Pro 2009 4,1>5,1 Dual Quad Core 2.93ghz 32gb ECC RAM. Sapphire Dual-X 7970 3 gb flashed. Samsung 970 EVO M.2 High Sierra 10.13.6
960 EVO Mojave 10.14.4 bootrom 141.0.0.0.0
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #276 on: February 07, 2016, 11:15:25 PM »

SMIKX That is a meal worth coming home for. Great to see you got the 4,1 and are happy with it.

One quick question. Can I use the 5870mod.efi I downloaded from your post for port mapping on page 15 and just stitch it with the original bios of the 5870 then flash the card for all ports showing boot or will I have to edit further? I have the exact same card as you.

Thanks

TC



Yes, it initially feels frightening but ends up being highly educational .. no pain, no gain.

Nothing quite matches seeing the Apple pop up on the monitor.

 . .. . .  AND  > > > I finally got hold of a MAc Pro 4,1 ! Yeah!

Well worth the effort. Thanks to Fl0r!an.

I'm off to OZ ( Australia ) in April ( Brisbane ) . . gonna amble down to the Brekky Creek Hotel for some yummy Barramundi Mate !

SMIKX I am sort of glad you would not post or send me your efi roms at the time but I did think that was just not right! We're Australian after all!  Smiley
BUT, once I found the time (very hard with 3 kids and Christmas holidays) and get the courage to spend the 30 minutes to stitch the rom and flash the bios it was indeed easy. Thanks to the fantastic information here I now have a good efi rom and the original tucked away for my 5870.

I will now have to try to see how to port map as I only have boot screen on DVI/VGA adaptor.

TC


I side with Rominator in that it took me ages to muster up the courage to go through sewing efi & Fl0r!an's roms together.

Doing it yourself, engaging in the 'learning process' can't be a negative thing.

Fl0r!an insisted that it was not hard, encouraged me to try and in fact it wasn't and by doing it by myself instead of waiting for a rom to appear here I have enriched my Mac hacking abilities and understanding of 'How Mac things work '.

I now have EFI roms for my HD  5770's and HD 5870's ( 2 each ). Now that I know how easy the sewing process actually is I will not post them here as the EFI parts are already here in these pages.

Happy, safe and prosperous New Year too all.

Kyoto, JAPAN.



This is a Barramundi.


Logged
Spacedust
Sr. Member
****
Offline Offline

Posts: 405


« Reply #277 on: February 12, 2016, 04:53:52 PM »

We've got another no-EFI card ;(

Sapphire Dual-X HD7850 2 GB GDDR5 - boot screen works but when entering OS X instant restart.



The 2x mDP version works well.
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 92



« Reply #278 on: February 13, 2016, 01:54:45 PM »

Techchallenged, I have TWO 5870's

Vapor-X O/C 5870  &  HIS 5870

I used the Fl0r!an efi you mentioned in your above post for both. I'm using a DVI-HDMI cable.

Both work and yield boot screens.

Also, DVI - VGA adaptor to VGA works too but above HDMI setup is nicer.
Logged

Mac Pro 2009 4,1>5,1 Dual Quad Core 2.93ghz 32gb ECC RAM. Sapphire Dual-X 7970 3 gb flashed. Samsung 970 EVO M.2 High Sierra 10.13.6
960 EVO Mojave 10.14.4 bootrom 141.0.0.0.0
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #279 on: February 14, 2016, 02:41:26 AM »

Thanks SMIKX I have the Vapor-X. After stitching I get a file 174kb in size. Before I flash is does that look right to you? I will be using DVI to HDMI cable also.

Cheers

TC

Techchallenged, I have TWO 5870's

Vapor-X O/C 5870  &  HIS 5870

I used the Fl0r!an efi you mentioned in your above post for both. I'm using a DVI-HDMI cable.

Both work and yield boot screens.

Also, DVI - VGA adaptor to VGA works too but above HDMI setup is nicer.
Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 92



« Reply #280 on: February 14, 2016, 06:32:13 PM »

No, my Vapor-X rom is 131 kb after sewing.

Did you run fixrom.py  as Netkas's guide states?
Logged

Mac Pro 2009 4,1>5,1 Dual Quad Core 2.93ghz 32gb ECC RAM. Sapphire Dual-X 7970 3 gb flashed. Samsung 970 EVO M.2 High Sierra 10.13.6
960 EVO Mojave 10.14.4 bootrom 141.0.0.0.0
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #281 on: February 16, 2016, 09:03:13 AM »

No, my Vapor-X rom is 131 kb after sewing.

Did you run fixrom.py  as Netkas's guide states?


Hi Smikx I used the 42kb efi version and got finished rom of 131kb. Can you take a look at this rom for me before I flash.
Thanks Smikx
TC

* MYROM.ROM (128 KB - downloaded 562 times.)
« Last Edit: February 29, 2016, 11:33:21 PM by Techchallenged » Logged
SMIKX
Jr. Member
**
Offline Offline

Posts: 92



« Reply #282 on: February 16, 2016, 04:05:45 PM »

Looks OK but of course  . . .  you  backed up the original rom . .. .

( if you haven't backed up the original rom . . stop now and do it. )

If you do have a backup . .go ahead and flash it.

After the flash you might have to try both DVI ports on the card .. I'm using a 5770 at the moment so the 5870 is different ( I think ).
Logged

Mac Pro 2009 4,1>5,1 Dual Quad Core 2.93ghz 32gb ECC RAM. Sapphire Dual-X 7970 3 gb flashed. Samsung 970 EVO M.2 High Sierra 10.13.6
960 EVO Mojave 10.14.4 bootrom 141.0.0.0.0
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #283 on: February 17, 2016, 04:54:44 AM »

Looks OK but of course  . . .  you  backed up the original rom . .. .

( if you haven't backed up the original rom . . stop now and do it. )

If you do have a backup . .go ahead and flash it.

After the flash you might have to try both DVI ports on the card .. I'm using a 5770 at the moment so the 5870 is different ( I think ).

Thanks for having a look SMIKX I have the original file backed up for safe keeping. If I have time tonight I will give it a go.
Thanks again.
Logged
Techchallenged
Not Newbie
*
Offline Offline

Posts: 11


« Reply #284 on: February 22, 2016, 01:25:42 AM »

Looks OK but of course  . . .  you  backed up the original rom . .. .

( if you haven't backed up the original rom . . stop now and do it. )

If you do have a backup . .go ahead and flash it.

After the flash you might have to try both DVI ports on the card .. I'm using a 5770 at the moment so the 5870 is different ( I think ).

Thanks for having a look SMIKX I have the original file backed up for safe keeping. If I have time tonight I will give it a go.
Thanks again.

Hi SMIKX, I have had success with DVI-HDMI cable for boot screens. DVI-VGA adaptor works as before also.  Smiley

Straight HDMI to HDMI caused the system to hang on boot with apple logo and grey box behind it. I PRAM reset and it still hung. I switched back to DVI-HDMI cable then rebooted and held alt to boot into alternate lion disk. Once in Lion I then restarted back into my El-Captain disk which now boots fine with boot screens as mentioned above.

I have not tested DP yet. But I am happy with the result at having boot screen on DVI ports without having to switch to VGA on monitor. It really is cool to have the boot screens back so I can switch between boot disks.

Now to update 10.11.1 to 10.11.3.
Thanks for your help.

TC
« Last Edit: February 22, 2016, 01:28:06 AM by Techchallenged » Logged
Pages: 1 ... 17 18 [19] 20 21 ... 24
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!