netkas.org forum
August 17, 2019, 02:45:36 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 6 7 [8] 9 10
 71 
 on: April 01, 2019, 04:52:36 PM 
Started by netkas - Last post by R2K
Hi guys, I was able to successfully flash an MSI R9 270x Gaming 2GB with the instructions in this topic, combined with a different patched efi.
Before flashing, the card was working fine in a 2009 Mac Pro (4,1 flashed to 5,1), with MacOS 10.14.4 and Mac firmware 141.0.0.0.0. As I understood, this firmware als enables 5.0 GT/s mode, so no R17 hack needed.
Card was detected as AMD Radeon HD 7xxx. Both DVI outputs working, unable to test HDMI and Displayport because I don’t have matching monitors or adapters.
I needed boot screens because I want to enable Filevault on my boot drive.

Started with the instructions and files from the first post in this topic. I flashed one of the roms (this card has dual roms, one legacy and one hybrid (legacy+UEFI)).
Boot the system, and yes! Boot screen on the bottom DVI. Was a happy puppy for about 15 seconds, because when the system (10.14.4) loaded the driver at login screen, all went black. Tried both DVI outputs, both black. Reverted the rom, and patched&flashed the other rom on the card. No difference.
I could access the system through screen sharing though, system profiler showed the card correctly as a 7950, so why was it not working?
Read some more, and I understood that this could be a framebuffer/port layout issue (maybe in combination with Metal/Mojave?)
So..I got either a card with boot screen but not working in the OS, or one without boot screen but working in the OS with the default RadeonFramebuffer.

Then I found this post in the Radeon Port mapping topic.
Here Fl0r!an posted an efi file with a purposely broken framebuffer. Theoretically, if I understand well, this causes the OS to not recognize the framebuffer set by the efi, and instead use the default RadeonFramebuffer.
I used the commands from the first post to patch my rom, but using Florian's RFB.efi instead of 7950mac.efi.
Flashed the rom, and it’s working! Boot screen on the bottom DVI (not on the top DVI, and HDMI and DisplayPort untested). When booted into the OS, both DVI ports are working. Again, HDMI and DisplayPort untested.

So I’m very happy, but still a question:
- The card now shows up as AMD Radeon HD 7xxx (Type DisplayController, with driver loaded) and AMD Radeon 7970 (Type ATY,HamachoParent, with no driver loaded). Where I think 'Hamacho' is where Florian changed 'Hamachi' to ‘disable’ the framebuffer.
Is there any disadvantage of it showing up also as a 7970? Probably because the RFB.efi was based an a 7970, but since (I think) it’s not used when the system is booted, it’s no problem? Everything seems to be working ok. Or could there be an advantage by patching 7950mac.efi the same way Florian did, and using that?

Rom and screenshots attached.

 72 
 on: March 31, 2019, 03:53:12 AM 
Started by Rominator - Last post by lowrider
^^^^The pulled 108 driver is NOT patched.  It has worked, as downloaded, on all iterations of HS 10.13.6.  And if I recall correctly it worked fine on 10.13.5.

Lou

 73 
 on: March 31, 2019, 01:22:30 AM 
Started by Rominator - Last post by mysticalos
Why would you patch 108 to work on it instead of patching 223 the SAME way to work on it?

I literally did a one line terminal command and rebooted and was good to go. whatever 17G6030 fixed was important enough to push it to users who had 17G6029. often apple makes newer builds but only pushes them to people who don't have previous one. This one they pushed to EVERYONE.

 74 
 on: March 30, 2019, 08:10:05 PM 
Started by Rominator - Last post by lowrider
Apple modified Security Update 2019-002 this morning.  Why not change the designation, I do not know Huh  Anyway the new build no. is (17G6030).  The Driver anding in 123 no longer works.  The pulled 108 Driver is still working along with Cuda.

Lou

 75 
 on: March 30, 2019, 08:05:44 PM 
Started by Rominator - Last post by lowrider
^^^^This thread is for builds of the Web Driver for High Sierra.  Not Sierra.  You may want to post your findings here:

http://forum.netkas.org/index.php/topic,11579.0.html

Lou

 76 
 on: March 29, 2019, 08:17:43 PM 
Started by Rominator - Last post by Synchro03andsoon
The new driver for Sierra 10.12.6 is 378.05.05.25f14.   F13 is the old one.

http://us.download.nvidia.com/Mac/Quadro_Certified/378.05.05.25f14/WebDriver-378.05.05.25f14.pkg

 77 
 on: March 27, 2019, 11:39:38 PM 
Started by Rominator - Last post by Spacedust
New drivers:

- for High Sierra: https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.123.pkg

- for Sierra: https://images.nvidia.com/mac/pkg/378/WebDriver-378.05.05.25f13.pkg

 78 
 on: March 21, 2019, 06:02:17 AM 
Started by Rominator - Last post by Tpluth

did somebody else already figure it out?


Looks like we're still waiting on your brilliance!  What can we do to help?

Does anyone know the number for LAPD's missing persons bureau?  Rominator is MIA!

Nevermind. I scored a 2012 base 27" iMac (i5 2.9GHz GTX660M 16GB).  I'm gonna upgrade it to an i7-3770 and 768GB blade SSD and call it a day.

Anybody need a 780M, 770M, 765M or some Dell 2GB 6970M's or Dell 7970M's?

 79 
 on: March 14, 2019, 04:34:06 PM 
Started by netkas - Last post by SMIKX
( this thread for 7970 Sapphire Dual-X owners )

Last year I got a Sapphire Dual-X 7970 3gb here in japan for ¥6,500 ( US$58 ).

I successfully flashed it and got it to run at 5.0gb/s in High Sierra and it now runs nice and quiet with an EVGA PowerLink connected.

This model has two fans and I eventually noticed that the rear fan spins up at startup and then shut down.

Tonight I ran Sapphire's Trixx in Win 7 and sure enough when I entered the FAN section in Trixx the rear fan started spinning. So it does work !

Trixx showed that tonight ( March = winter in Japan ) the ambient case temp was 24°C and the front fan was spinning at 28% of capable speed.

Japan's hot & humid summer is rapidly approaching so I have set the fans to 60% when the card's senors hit 50°C. Hopefully that is when the 2nd. fan should spin up.

So apparently the 2nd. fan spins up when the card gets to a set temp.

I will see what happens when where I live in Japan hits 40°C. outside.

I hope that this info is useful for any cMP Dual-X owners.

NOTE
:  Google showed numerous ( 67,000 ) posts regarding the Dual-X 's 2nd. fan not spinning up. https://www.google.com/search?source=hp&ei=wXKKXOuMO8b38QX_nJHABQ&q=Sapphire+Dual-X+7970+2nd.+fan+not+spinning&btnK=Google+Search&oq=Sapphire+Dual-X+7970+2nd.+fan+not+spinning&gs_l=psy-ab.3...2495.47181..49237...0.0..0.246.5760.25j22j3......0....1..gws-wiz.....0..0j0i10j0i13j0i13i30j0i13i5i30j0i8i13i30j0i8i13i10i30j33i160j33i21.nZSOhe7g-d4

 80 
 on: March 13, 2019, 08:52:16 PM 
Started by MacEFIRom - Last post by brandonp1311
I am performing a firmware update on a 2006 1,1 Mac Pro:

Boot ROM Version: Mp11.005C.B08
SMC Version: 1.7f10
OS X 10.7.5

Nothing in the Mac Pro besides the Hard Drive and stock NVIDIA 7300GT Video Card.

I have done dozens of these firmware updates successfully.  However, this time I am running into the following message:

The program has encountered an error: 5530.

Any help would be great!

Pages: 1 ... 6 7 [8] 9 10
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!