netkas.org forum

General Category => OSX and Graphics Cards => Topic started by: Rominator on June 12, 2013, 12:10:03 AM



Title: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: Rominator on June 12, 2013, 12:10:03 AM
Put an EFI flashed 7970 in 10.9 and it is suddenly a FirePro.

Guess that driver is done already.

Also discovered that GTX770 is already supported in 10.9

GTX Titan finally gets OpenCl, though the waves thingey seems stuck on 60fps, seems like sync is stuck on


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: trevize on June 12, 2013, 03:08:06 PM
Nice!   Glad I just bought a 7970.   :-)


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: blacksheep on June 12, 2013, 03:20:37 PM
though the waves thingey seems stuck on 60fps, seems like sync is stuck on

Same here with 7950.
mitch.de must update Wave to work with 10.9 properly.


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: armdn on June 14, 2013, 02:17:11 PM
Is "cold bug" with HD 7000 series still present in 10.9?


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: blacksheep on June 15, 2013, 02:39:12 AM
Yeah, unfortunately it is. My above post was regarding 4,1.

Now I've tried 7950 in 1,1 with mixed results (Chameleon 2247):
– GE = Yes – cold bug but all works (QE/CI, OCL)
– GE = No – no cold bug, no QE/CI. OCL works.

Will investigate that further.


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: armdn on June 17, 2013, 08:40:18 AM
Interesting thing i located - when i reinstall my 10.8.3 with 6870 - it is also appeared cold bug with InstallESD, sleep trick worked, but no bugging with 4870 Mac Edition... Chameleon 2247.


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: blacksheep on June 17, 2013, 10:28:37 AM
Got 7870 XT working in 10.9 without white screen and with full QE/CI. Without GraphicsEnabler. But with default RadeonFramebuffer. When I'm trying to load Hamachi, white screen comes back. Card is recognized as 7xxx by ASP and uses "fake" FirePro D500 (W8000) OGL engine. Performance's good.


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: armdn on June 17, 2013, 05:41:30 PM
Is PCI Devices shown up in System Profiler?


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: blacksheep on June 19, 2013, 12:25:14 AM
No, I'm getting usual error in PCI cards info.
Dual displays work.


Title: Re: 10.9 & 7970 = NewMac Pro FirePro is here...already. Titan Gets OpenCl
Post by: omni on June 23, 2013, 09:35:38 PM
GTX Titan finally gets OpenCl, though the waves thingey seems stuck on 60fps, seems like sync is stuck on

Same happens for me with GTX 570, so it could be all Nvidia...