netkas.org forum

General Category => OSX and Graphics Cards => Topic started by: overshoot on April 10, 2019, 05:03:10 AM



Title: GTX780 ti - Best option for MacPro 5.1 with Mojave???
Post by: overshoot on April 10, 2019, 05:03:10 AM
Hi,

I am about to buy a GTX 780 Ti from macvidcards-europe and I am wondering if that's the best choice for performance/compatibility ratio?!
As I do understand, the GTX 7XX family is natively supported in Mojave because of the drivers being present.
Having a macvidcards will allow me to have the boot screen which is pretty important to me.

The last bit that I am unsure is: are the drivers integrated in Mojave ensuring that this card will be used as its full potential or not?!
Also I've read of potential issues with the PSU not being able to supply enough wattage at some point?!

I am using Premiere Pro with After effects and a powerful but compatible GPU is necessary for real time rendering.

I was thinking of the RX 580 at first, but the lack of boot screen made me look elsewhere.

What do you guys think?


Title: Re: GTX780 ti - Best option for MacPro 5.1 with Mojave???
Post by: Spacedust on April 10, 2019, 10:40:09 AM
Yes, it's the best option.

Drivers are inside macOS Mojave so it will be always supported.

PSU will handle this GPU without any problems.


Title: Re: GTX780 ti - Best option for MacPro 5.1 with Mojave???
Post by: overshoot on April 14, 2019, 05:09:54 AM
Thanks!

I’ll order it ASAP


Title: Re: GTX780 ti - Best option for MacPro 5.1 with Mojave???
Post by: goodfidelity on August 31, 2021, 07:33:09 PM
Hi guys!

I have Mac Pro 5.1 and trying to run a GTX 780 with the rom file that is listed on the mac elite wiki website.

Running bootcamp the card boots and runs in windows.

However trying to boot into OSX High Sierra the card will freeze after about 2/3s of the boot bar.

And if i flash the original PC ROM back onto it, it will not start in OSX either.

I was under impression it should run just as fine as GTX680, and i have tried MANY of those cards with no problem.

Is there something obvious that i am missing? Do i need to install the web-drivers or not?

Thanks for any input!