netkas.org forum

General Category => eGPU => Topic started by: Rominator on March 11, 2018, 04:24:16 AM



Title: 10.13.4 Beta 4, 5, 6, 7 all good with TB2 eGPUs working fine
Post by: Rominator on March 11, 2018, 04:24:16 AM

Running some benchies over on my 6,1 nMP on a 1080 in Beta 4 of 10.13.4

Pulled out the boxes, busted out the gear, and had it up and running in minutes

Not sure why they are so quick to throw up their hands and declare Apple the victors.

They should try firing up a computer and eGPU and doing some work, instead of whinging.

If you are always waiting for someone else to put out a "script" you don't achieve much.

If it sags, you aren't working.

UPDATE: Beta 5 in, still works


Title: Re: 10.13.4 Beta 4 & TB2 eGPUs working fine
Post by: muellmaa on March 12, 2018, 08:01:55 AM
great work!

did you manage to fix some issues barefeats faced when testing (screen turning black under certain circumstances)?

When can such cards be bought? Don't think of any solution coming from the egpu.io people :-)


Title: Re: 10.13.4 Beta 4 & TB2 eGPUs working fine
Post by: Spacedust on March 12, 2018, 06:03:31 PM
Great stuff! Simply ignore other forums, not worth the nerves.


Title: Re: 10.13.4 Beta 5 & TB2 eGPUs working fine
Post by: Rominator on March 13, 2018, 02:31:39 AM
Updated and tested, all still good.


Title: truth being omitted
Post by: Rominator on March 14, 2018, 09:58:02 PM
lots of hand wringing going on on the "experts" board

They've committed to the "10.13.4 breaks TB1/TB2 egpus" narrative when in fact, they just haven't figured out what changed and how to fix it.

I would post over there with the good news  but I was banned and all my posts removed. Nando did same thing at the board he ran before. (I got an email from owner apologizing for the bad behavior)

TB1/2 will be fine, at least I can speak for Nvidia.

News coming on TB3 eGPU via EFI...



Title: Re: 10.13.4 Beta 4 and Beta 5 & TB2 eGPUs working fine
Post by: Spacedust on March 17, 2018, 09:26:14 PM
It's always better to test on your own.


Title: Re: 10.13.4 Beta 6 & TB2 eGPUs working fine
Post by: Rominator on March 20, 2018, 07:55:54 AM
New Beta 6, still good.



Title: Re: 10.13.4 Beta 4, 5, & 6 all good with TB2 eGPUs working fine
Post by: Spacedust on March 27, 2018, 01:17:17 PM
Does Beta 7 still work?


Title: Re: 10.13.4 Beta 4, 5, & 6 all good with TB2 eGPUs working fine
Post by: muellmaa on March 28, 2018, 08:58:02 PM
who cares if it's not released (a.k.a. buyable) ???


Title: Re: 10.13.4 Beta 7 all good with TB2 eGPUs working fine
Post by: Rominator on March 29, 2018, 06:28:09 AM
Does Beta 7 still work?

Yep, working fine.

The point here is that the current alarmist "Apple has discontinued eGPU for TB1/2 Macs" is gibberish spouted by people who just can't figure out what changed.

The eGPU community should be thrilled that there will be plenty of options going ahead, instead of wringing their hands over a non-existent (or self created) problem.


Title: Re: 10.13.4 Beta 4, 5, 6, 7 all good with TB2 eGPUs working fine
Post by: tico on March 29, 2018, 08:10:21 PM
Thats great when using that configuration, however the 10.13.4 beta 2 refresh broke my eGPU support & the only thing improved with the subsequent beta's was that my machine didn't immediately crash when the egpu was plugged in. It may be the fact I'm using a 2014 rMBP with a discreet GT750m chip. It has worked fine in 10.12.3 with a Vega 64, GTX680, and a GTX 1080(hoping for drivers for my Titan V) in both a Sonnet breakaway & a Mantiz. Have you tried it with a MacBook Pro with discreet graphics?
thanks
jeff


Title: Re: 10.13.4 Beta 4, 5, 6, 7 all good with TB2 eGPUs working fine
Post by: Spacedust on March 29, 2018, 09:27:40 PM
We do all wait for final 10.13.4 version and it should come very soon ;)


Title: Re: 10.13.4 Beta 4, 5, 6, 7 all good with TB2 eGPUs working fine
Post by: tico on March 30, 2018, 06:56:05 PM
10.13.4  :-X :'( :'( :'( :'( :'( :'( :'( :'( at least with TB1 & TB 2 Mac Book Pros :-[ :-[ :-[ :-[ :-[ :-[
Looks like Apple forsake a huge part of their Mac customers. Unless there is a compelling technical reason for the eGPU's not to work using TB1 & TB2.  I haven't heard of any.
I can't even purchase a TB3 Mac of any kind thanks to Apple's new security chip & High Sierra requirement.  Our management has prohibited all Mac purchases at least to July, oops now its November.
Thats 4K Macs not sold & on hold. Really screwing up my research.


Title: Re: 10.13.4 good with TB2 eGPUs working fine
Post by: Rominator on March 30, 2018, 07:55:39 PM
I guarantee that there is a way to run 10.13.4 on TB1/2 Macs and use eGPU.

I'm going to update my nMP, Air and Mini and test.

The way that eGPU "experts" board has worked in past is that it has counted on some clever soul to come by and solve the current issues. This wandering genius posts a fix, then the more exuberant members write a "script" to use whatever the wandering genius found. Genius vanishes, exuberant code kiddie keeps their "script" updated for the masses.

I'm going to guess that as the hue & cry increases about 10.13.4 "killing" TB1/2 support one of these clever folks will show up and solve the problem. They will then post a public fix.

Just a matter of time.


Title: Re: 10.13.4 good with TB2 eGPUs working fine
Post by: tico on March 30, 2018, 10:09:53 PM
I guarantee that there is a way to run 10.13.4 on TB1/2 Macs and use eGPU.

I'm going to update my nMP, Air and Mini and test.

Hopefully you can get to to work for the rMBP’s with the discreet gpu. I think the dGPU will be a problem.