netkas.org forum
August 11, 2020, 04:18:47 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: P35 Success & PC_EFI v8 BUG!  (Read 37624 times)
tom3q
Not Newbie
*
Offline Offline

Posts: 12


« on: December 30, 2007, 08:19:59 PM »

Hi.

I'm proud to announce that i've got my 8600GT working on P35 chipset with GFX-string!
At first, i have to say that i've discovered some weird bug in PC_EFI v8... it breaks GFX-strings. It changes some parts of GFX-string randomly, like 0x8C to 0x6C. The way i've got it to work was using PC_EFI v6 with hardcoded GFX-string (attached to this post). To fix GFX-string for P35 support i had to change ACPI address of PCI Root Bridge from PNP0A03,0 to PNP0A03,1. So if you have d0 41 03 0a 00 00 00 00 in GFX-string you have to change it to d0 41 03 0a 01 00 00 00 and then it will (hopefully) work with your P35 board.

Regards
tom3q

Edit:
Now my OpenGL performance in GLView is similar to performance under Windows Vista.

* boot_gf8600_p35.rar (33.29 KB - downloaded 452 times.)
« Last Edit: December 31, 2007, 08:36:24 PM by tom3q » Logged
pm_mickey
Newbie

Offline Offline

Posts: 4


« Reply #1 on: December 31, 2007, 01:49:07 AM »

Works on my MB too Gigabyte ga-p35-ds4 and gigabyte 8600 gt 256 mb!!!
Thanks!  Grin
Logged
lmf128
Newbie

Offline Offline

Posts: 2


« Reply #2 on: December 31, 2007, 05:23:20 PM »

I've got my GA-965P-DS4 and XFX7600GT 256M working with PC_EFI v8 now with Thrawnhex's gfx-string and change d0 41 03 0a 00 00 00 00 to 0 41 03 0a 01 00 00 00. It didn't work without changing the gfx-string.

Thanks both tom3q and Thrawnhex  Smiley
Logged
eclau
Not Newbie
*
Offline Offline

Posts: 17


« Reply #3 on: December 31, 2007, 06:43:59 PM »

Also I'd like to report success on my system Gigabyte GA-P35-DS4 with 7600GS 256Mb after the above changes to the string...

Thanks Thrawnhex and tom3q!
Logged

Vanilla Leopard, 10.5.1 update, PC_EFI v8
Gigabyte P35-DS4 rev 2.0
Intel Q6600
4x1gb Corsair DDR2 667MHz
Nvidia GeForce 7600GS 256mb @ 1680x1050 Samsung SyncMaster 226BW
2x320gb Western Digital AAKS SATA II
Pioneer DVD-RW DVR-212BK SATA
Onboard Realtek 8111B LAN
Onboard Realtek ALC889A audi
aliab
Not Newbie
*
Offline Offline

Posts: 6


« Reply #4 on: January 01, 2008, 12:19:41 PM »

Thank you very much Eclau
succes here 
Efi_v8
Asus en7300gt Silent
P35-DS3P
Logged
mtrr
Not Newbie
*
Offline Offline

Posts: 27


« Reply #5 on: January 01, 2008, 01:08:23 PM »

aliab:

could you point me to the string you started with? (before the edit)

tia


Logged
aliab
Not Newbie
*
Offline Offline

Posts: 6


« Reply #6 on: January 02, 2008, 12:11:35 AM »


<string>7e0200000100000001000000720200000e00000002010c00-d041030a0100000-0101060000010101060000007fff04000e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000024000000400030002c005600520041004d002c006d0065006d00730069007a00650000000c00000000000004000000081c0000006400650076006900630065005f0074007900700065000000100000004e5644412c4765466f7263650e0000006e0061006d00650000000f0000004e5644412c506172656e7422000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c617922000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000006d006f00640065006c000000170000004765466f72636520373330302047542045464920000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d4114000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d61631e00000072006f006d002d007200650076006900730069006f006e0000000800000033313735100000004e00560043004100500000001800000004000000000003000c000000000000070000000024000000400031002c005600520041004d002c006d0065006d00730069007a00650000000c0000000000000400000008
</string>
« Last Edit: January 02, 2008, 12:15:05 AM by aliab » Logged
B666
Not Newbie
*
Offline Offline

Posts: 16

closer to g0d


« Reply #7 on: January 02, 2008, 01:05:17 AM »

I've got my GA-965P-DS4 and XFX7600GT 256M working with PC_EFI v8 now with Thrawnhex's gfx-string and change d0 41 03 0a 00 00 00 00 to 0 41 03 0a 01 00 00 00. It didn't work without changing the gfx-string.

Thanks both tom3q and Thrawnhex  Smiley

Dude, i have a 7600gt too, but i change the line and don't work, maybe i made something wrong.. if possible, paste your string here, plz?
Thanx!
Logged
mtrr
Not Newbie
*
Offline Offline

Posts: 27


« Reply #8 on: January 02, 2008, 04:26:56 PM »

aliab:

thank you, didn't work on my GA-P35-DS3 with 7300gt


cheers
Logged
tom3q
Not Newbie
*
Offline Offline

Posts: 12


« Reply #9 on: January 02, 2008, 04:42:23 PM »

aliab:

thank you, didn't work on my GA-P35-DS3 with 7300gt

cheers

Could you install XCode Tools and check with IORegistryExplorer if your efi device-properties are the same as entered in com.apple.Boot.plist? I found that in some computers PC_EFI v8 does something weird to entered string.
« Last Edit: January 02, 2008, 05:29:14 PM by tom3q » Logged
mtrr
Not Newbie
*
Offline Offline

Posts: 27


« Reply #10 on: January 02, 2008, 05:24:50 PM »

tom3q:

strings are not identical Sad last character is missing in the ioreg output

...000000000000040000000   <- ioroeg output
...0000000000000400000008 <- Boot.plist

seems I need to stay with NVinject

cheers
Logged
tom3q
Not Newbie
*
Offline Offline

Posts: 12


« Reply #11 on: January 02, 2008, 05:30:38 PM »

So apparently, gfx-string support of PC_EFI v8 is buggy... Netkas, could you fix that?
Logged
mtrr
Not Newbie
*
Offline Offline

Posts: 27


« Reply #12 on: January 02, 2008, 05:33:06 PM »

tom3q:

for testing purpose I'm going to append a character to my gfx-string and reboot (with fingers crossed....)
Logged
mtrr
Not Newbie
*
Offline Offline

Posts: 27


« Reply #13 on: January 02, 2008, 05:48:01 PM »

darn!

if I append something (e.g. a "0") it's in the iroeg output => no go, if I use the plain string => no go


cheers
Logged
tom3q
Not Newbie
*
Offline Offline

Posts: 12


« Reply #14 on: January 02, 2008, 08:48:13 PM »

mtrr:

Are you sure that these strings differ only by last character?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!