netkas.org forum
September 27, 2020, 09:28:16 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 ... 7 8 [9] 10 11 ... 35
  Print  
Author Topic: make your own radeon HD 5770/5870/6870/6850 Mac ROM!  (Read 1145473 times)
Rominator
Hero Member
*****
Offline Offline

Posts: 2346



« Reply #120 on: September 16, 2011, 01:32:04 AM »

I have tried a variety of flashed 5870 cards and almost NONE of them will run an Apple LED Cinema Display.

And for once, the issue has nothing to do with Apple. There was some misunderstanding between ATI and someone over the Displayport spec. It is supposed to be pin for pin compatible with Mini-Displayport. (in other words, same wires and connections, just different plug on the end)

Reality is that many early DisplayPort 5870 cards used some minor tweak to this that does not allow the use of a MiniDisplayport adapter to run a Cinema Display. This also applies to most 5770 cards. If the card actually has a MiniDisplayport, it will likely work just fine with an Apple Display. It is only the ones that Have the larger DIsplayport output on them that have the issue.

In my experience, ALL Manufacturers who used the Reference design have this issue. I discovered that XFX instituted a fix in their 2nd series of 5870s. The later boards that had the fan in center, instead of at end are the ones that got fix.

The DRAG is that the first versions of those cards still had bug...in my experience I have seen V 1.3 cards that had bug. IIRC it is the V 1.5 cards that started working well and could run the Apple LEDs just fine. I am certain that a V 1.8 can run an Apple Display with no issues at all.

I do not know the version numbers for the 5770 cards. It is of course much easier to just use a 6870 and have 2 @ MDPs, but for anyone wanting that extra EDGE that 5870 has, there is the info.

If anyone else has a follow-up with more info, please post.

And BTW, I can also verify that the issue had nothing to do with software, i.e. whichever ROM on the early cards means LOCKUP when MDP plugged in while whichever ROM on later cards had no issue. SO something in the hardware got revised.

On another note...this exact same info applies to Hackintosh crowd. I have seen reports of Hack folks buying APple 5770/5870 so they could run an Apple Display. (anyone else catch the irony?)
Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
Vollstein
Not Newbie
*
Offline Offline

Posts: 10


« Reply #121 on: September 16, 2011, 12:14:52 PM »

jeffleeismyhero, i'm tried flashin the 6870 xfx card

i'm tried this
Quote
blocknum=`printf %d "'\`dd if=myrom.rom bs=1 skip=2 count=1 2>/dev/null\`"` && blocknum=${blocknum#-}
size=$(($blocknum * 128))
dd if=6870.efi.rom of=myrom.rom bs=$size seek=1 conv=notrunc
then
Quote
python fixrom.py myrom.rom myrom.rom
screenshots attached
..how i may fix this and completely flashed my 6870 card? please help some one...


* 2011-09-25 в 5.10.10.png (74.15 KB, 596x379 - viewed 1653 times.)

* IMG_0692.JPG (236.66 KB, 989x626 - viewed 1562 times.)

* IMG_0693.JPG (228.86 KB, 772x609 - viewed 1467 times.)
« Last Edit: September 25, 2011, 02:45:41 AM by Vollstein » Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #122 on: September 24, 2011, 10:11:27 PM »

Hi! I'm too always getting the "dd: bs must be between 1 and 9223372036854775807" code with XFX 6870. Help some one please.. maybe Jeanlain? Smiley


Same Prob here. Seems like they switched the revision of that card. Mine has v.5 on the background.

Edit: When I repeat Vollsteins suggestions I could flash the myrom.rom which is being made to the card in DOS/Atiflash even without to force flash with -fs -fp. But then the card went into constant reboot/crashes, so I flashed the original Bios again. BTW the card now has Elpida Ram instead of Samsung/Hynix (earlier revisions).

I attached the original Bios of the HD-687A-ZDFC and the Rom which the script produced. Maybe that helps.


* HD-687A-ZDFC.rom (128 KB - downloaded 653 times.)
* myrom.rom (128 KB - downloaded 660 times.)
« Last Edit: September 25, 2011, 08:05:56 AM by mac-bitch » Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #123 on: September 25, 2011, 08:43:44 AM »

Hey Vollstein, maybe I noticed our mistake.

The line must be

blocknum=128
size=$(($blocknum * 512))
dd if=6870.efi.rom of=myrom.rom bs=$size seek=1 conv=notrunc
python fixrom.py myrom.rom myrom.rom

I made a file which I could successfully flash without force (atiflash -p 0 myrom.rom) to the card.

I attached the rom.

* myrom.rom (128 KB - downloaded 705 times.)
Logged
Vollstein
Not Newbie
*
Offline Offline

Posts: 10


« Reply #124 on: September 25, 2011, 11:35:27 AM »

yes .. there is a difference


* 2011-09-25 в 14.15.37.png (35.86 KB, 583x255 - viewed 1747 times.)
Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #125 on: September 25, 2011, 11:44:44 AM »

yes .. there is a difference
Please try the EFI in Post #126 and report back :-).
Logged
Vollstein
Not Newbie
*
Offline Offline

Posts: 10


« Reply #126 on: September 25, 2011, 11:59:01 AM »

is not necessary Cheesy Wink
big thanks!!!
my efid rom file is attached


* 2011-09-25 в 14.49.57.png (144.08 KB, 717x761 - viewed 1615 times.)
* myrom.zip (83.99 KB - downloaded 621 times.)

* 2011-09-25 в 15.16.05.png (103.72 KB, 592x339 - viewed 1597 times.)

* 2011-09-25 в 15.16.25.png (158.04 KB, 712x756 - viewed 1526 times.)
« Last Edit: September 25, 2011, 12:25:42 PM by Vollstein » Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #127 on: September 25, 2011, 12:08:28 PM »

is not necessary Cheesy Wink
big thanks!!!
my efid rom file is attached

Glad to hear that I could contribute to the community Smiley.
Logged
Vollstein
Not Newbie
*
Offline Offline

Posts: 10


« Reply #128 on: September 25, 2011, 12:28:06 PM »

glad to know that there are people who can help  Grin
many thanks Smiley
Logged
macattack
Not Newbie
*
Offline Offline

Posts: 19


« Reply #129 on: September 28, 2011, 08:39:22 PM »

Could any one of the guru's out there, please help. I have tried several attempts to my make my own XFX 5770 mac rom using this method on this post,  but had no success. I have attached my PC rom, for anyone kind enough to make it for me.

The video card is a XFX HD-577A-ZNFC VE.5 which I believe from this forum has been made to work. I used this method it flashes successfully, but does not display anything when mac boots.

blocknum=`printf %d "'\`dd if=myrom.rom bs=1 skip=2 count=1 2>/dev/null\`"`
size=$(($blocknum * 512))
dd if=5770_vervet_netkas.efi of=myrom.rom bs=$size seek=1 conv=notrunc


* myrom.rom (128 KB - downloaded 621 times.)
Logged
macattack
Not Newbie
*
Offline Offline

Posts: 19


« Reply #130 on: October 03, 2011, 11:40:00 AM »

could someone please please help,

I have tried making a custom rom. by sewing the efi to my pc bios as per this guide. the bios I make has two mcuc, but when installed in my mac pro I GET NO DISPLAY AT ALL!

Could someone please try making the rom for me! I am willing to pay someone if you get it to work.
Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #131 on: October 03, 2011, 12:49:55 PM »

could someone please please help,

I have tried making a custom rom. by sewing the efi to my pc bios as per this guide. the bios I make has two mcuc, but when installed in my mac pro I GET NO DISPLAY AT ALL!

Could someone please try making the rom for me! I am willing to pay someone if you get it to work.
[/quot

How do you try to attach your monitor to the card (DVI, VGA, etc.)?
could someone please please help,

I have tried making a custom rom. by sewing the efi to my pc bios as per this guide. the bios I make has two mcuc, but when installed in my mac pro I GET NO DISPLAY AT ALL!

Could someone please try making the rom for me! I am willing to pay someone if you get it to work.
Logged
macattack
Not Newbie
*
Offline Offline

Posts: 19


« Reply #132 on: October 03, 2011, 09:09:15 PM »

I connect via dual dvi, I know I have done it right, because I have flashed one before but a different brand & it worked fine. this XFX NFC ve5 it driving me crazy.
Logged
mac-bitch
Full Member
***
Offline Offline

Posts: 104


« Reply #133 on: October 04, 2011, 06:47:55 AM »

Please do not pay anyone for this. The specialists who can look into your ROM (could you please post the original BIOS PC-ROM, too? maybe I can try to make the EFI Rom - no promises!) have not been around here lately, but I am sure they will come back soon.
 Wink
Logged
macattack
Not Newbie
*
Offline Offline

Posts: 19


« Reply #134 on: October 04, 2011, 10:47:42 AM »

ok many thanks here it is Roll Eyes

* BACKUP.ROM (128 KB - downloaded 657 times.)
Logged
Pages: 1 ... 7 8 [9] 10 11 ... 35
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!