netkas.org forum
July 23, 2014, 11:08:24 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1] 2 3 ... 8
  Print  
Author Topic: Compatibility overview  (Read 54382 times)
lukenukem
Newbie

Offline Offline

Posts: 10


« on: September 06, 2010, 12:03:12 PM »

On this page I initially asked whether there was some kind of a table or an overview of setups that were confirmed to work. Since I haven't heard yet of any table or page that summarizes the compatibility of graphic cards/roms/mac pros I assume there doesn't exist any. Therefore, I have started to build this table. Since some people were confused by the example data (sorry for that), I removed this misleading data and started to fill in real data so that people can rely on it.

If you want to contribute, please post:

  • Type of your Mac Pro: 1,1 (2006) or 2,1 (2007) or 3,1 (2008) or 4,1 (early 2009) as in System Profiler)
  • Exact name of graphic card, memory, product code (see list below or ATI 5870 models list or ATI 5770 cards list)
  • ROM that you used
  • What is working/not working (e.g. no image during boot process, only one DVI port working etc)




Generally, the Apple Radeon Cards seem to work in all Mac Pro models although Apple only supports them in the Mac Pro Models 3,1 and 4,1.

Apple CardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
Apple ATI Radeon 5770Works (not officially supported by Apple)Works (not officially supported by Apple)WorksWorks
Apple ATI Radeon 5870Works (not officially supported by Apple)Works (not officially supported by Apple)WorksWorks



Overview of PC graphic cards

All cards below are PC cards that need to be flashed in order to work in Mac Pros. Of course, none of the configurations below are in any way supported by Apple. If you are going to flash a card, you do this at your own risk! You find assistance in the "How to flash a card" guide and the "Evergreen MacPro ROMs". Make sure to have installed 10.6.4 on your Mac Pro with the graphics update.

Generally, it can be said that EFI boot screen only works when the 5770er and 5870er cards are used with a DVI-VGA adapter.

If you don't find your card in the table, please have a look at the other posts in this thread. Keeping the table up-to-date is relatively timeconsuming, which is the reason I stopped doing it.

ATI Cards 5870 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
ATI Radeon HD 5870
1GB GDDR5 PCIE, Radeon HD 5870, 1.0GB GDDR5 850MH, PCI-Express
UnknownUnknownUnknownWorks with ATIuakari.rom.zip confirmed by Bolle ("everything works like a charm so far"). Tested with two 1080p displays connected via DVI. Other ports not tested yet. Only problem in OSX is that the fan runs a bit too fast (=loud) in idle.Probably works (same as on left)

Sapphire Cards 5870 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
SAPPHIRE HD5870 1GB GDDR5 (this one)
1GB GDDR5 PCIE, Radeon HD 5870
UnknownUnknownUnknownWorks with custom Sapuakari.rom confirmed by Elphiel ("Rom works absolutely perfect"). Fully functional under OSX with Displayport and DVI (HDMI was not tested yet).
SAPPHIRE HD 5870 Eyefinity 6 Edition (21161-10-40R)
Radeon HD 5870, 2.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
SAPPHIRE HD 5870 1GB GDDR5 PCIE (Game Edition) (11161-01-50R)
Radeon HD 5870, 1.0GB GDDR5, PCI-Express
UnknownUnknownWorks with limitations using  m5870sap.rom ROM confirmed by a atomic101 with XFX_uakari ROM. "Fan quite noisy, especially under load in cinema 4D."Probably works (same as on left)
SAPPHIRE Vapor-X HD 5870 (11161-03-50)
1GB GDDR5 PCIE, Radeon HD 5870, 1.0GB GDDR5, PCI-Express
UnknownUnknownWorks with limitations confirmed by a . No boot screen.Probably works (same as on left)
SAPPHIRE Vapor-X HD 5870 (288-1E140-200SA)
Radeon HD 5870, 1.0GB GDDR5 850 Mhz, PCI-Express
Works with limitations using  587XZF18_uakari.rom ROM confirmed by a post on Macbidouille with XFX_uakari ROM on 1.1 Mac ProProbably works (same as on left)Probably works (same as on left)Probably works (same as on left)
SAPPHIRE Vapor-X HD 5870 (11161-08-50R)
2GB GDDR5 PCIE, Radeon HD 5870, 2.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown


Sapphire Cards 5770 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
SAPPHIRE HD 5770 1GB ("Vanilla" version)
GDDR5 PCIE, Radeon HD 5770, 1.0GB GDDR5, PCI-Express
Works with limitations with m57702.ROM confirmed by Rominator. No EFI boot. Both DVI ports and HDMI working.Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)
SAPPHIRE HD 5770 (288-1E148-102SA)
Radeon HD 5770, 1.0GB GDDR5 850 Mhz, PCI-Express
Works with limitations using  m57702.rom confirmed by LukeNukem on 1.1 Mac Pro. Both DVI ports are working. Others have not yet been tested. Very silent in 2d mode (Mac Pro fans are louder). No EFI bootscreen.Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)
SAPPHIRE Vapor-X HD 5770 (11163-00-20R)
1GB GDDR5 PCIE, Radeon HD 5770, 1.0GB GDDR5, PCI-Express
Works with limitations with m57702.ROM confirmed by Kant. Both DVI and HDMI work. Display port could not be tested yet.Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)

XFX 5870 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
Radeon™ HD 5870 (HD-587X-ZNFV13)
1024 MB DDR5 DisplayPort  
UnknownUnknownWorks with limitations (confirmed by pegasusrjf) with ROM 587XZF18_uakari.rom, no boot screen,  works with 3 displays, 2 with DVI cables, and one with a PowerColor Displayport to Single-link DVI Adapter (Active Adapter).Probably works (same as on left)
Radeon™ HD 5870 (HD-587X-ZNFV)
1024 MB DDR5 DisplayPort  
Works with limitations (confirmed by aconu and nekonoko) with ROM 587XZF18_uakari.rom, no boot screen,  DVI ports both work,  Nekonoko wasn't able to get the DisplayPort to work with a 24" LED Cinema Display but this probably was due to the adapter he used. aconu reports that all outputs work, including VGA with DVI-VGA adapter, DP work (Dell 3008), triple 30" display work with 2 DVI-D+DP. At Macbidouille the same card was also successfully tested with all 4 ports work individually or in dual screen configurations. Aconu reports that fan seems not to be noisier than his Gainward 4870 Golden Sample (efficient design with 2 low RPM fan) and it seems to be much quieter than the ATI ref design. Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)
XFX Radeon HD 5870 Eyefinity6 (HD-587A-CNF9)
2.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
XFX Radeon HD 5870 (HD-587A-ZNF9)
1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
XFX Radeon HD 5870 (HD-587X-ZNDA)
1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
XFX Radeon HD 5870 (HD-587X-ZNFA)
1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown


XFX 5770 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
XFX Radeon HD 5770 XXX (HD-577A-ZNFA)
1.0GB GDDR5, PCI-Express
Almost works with m57702.ROM confirmed by jjalling. Boot screen shows up when using a DVI->VGA adapter but only in this setup. The card is working on DVI, DVI->VGA and HDMI.UnknownUnknownUnknown
XFX Radeon HD 5770 XXX (HD-577A-ZNDC)
875MHZ 1GB 5.2GHZ GDDR5 2XDVI HDMI Display Port DIRECTX11 PCI-E
UnknownUnknownWorks with limitations confirmed by
abccba using the "5770 vanilla design card,  efi part from imac" ROM
Probably works (same as on left)
XFX Radeon HD 5770 (HD-577A-ZNFC)
850MHZ 1GB 4.8GHZ GDDR5 2XDVI HDMI Display Port DIRECTX11 PCI-E2.0
UnknownUnknownWorks with limitations confirmed by
abccba using the "5770 vanilla design card,  efi part from imac" ROM
Probably works (same as on left)

Club 3D 5780 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
CLUB-3D HD 5870 Eyefinity 6 Edition (CGAX-58748DP)
Radeon HD 5870, 2.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
CLUB-3D HD 5870 Overclocked Edition (CGAX-58724DPO)
Radeon HD 5870, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown


Club 3D 5780 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
CLUB-3D HD5770 Eyefinity 5 (CGAX-57724DP)
Radeon 5770, 1.0GB GDDR5, PCI-Express, Retail
UnknownUnknownUnknownUnknown
CLUB-3D HD5770 OC Edition (CGAX-57724DPO)
Radeon 5770, 1.0GB GDDR5, PCI-Express, Retail
UnknownUnknownUnknownUnknown
CLUB-3D HD5770 (CGAX-57724I)
Radeon 5770, 1.0GB GDDR5, PCI-Express, Retail
UnknownUnknownUnknownUnknown
CLUB-3D HD5770 (CGAX-57724IDP)
Radeon 5770, 1.0GB GDDR5, PCI-Express, Retail, Ati Radeon 5770 Reference Design, black PCB, looks like Apple card, 2 DVI 1 HDMI 1DP
Comment by PoloBear:  "Crappy loud Cooler. Card is less noisy than in PC with original ROM but louder than ATI 4870"
UnknownUnknownWorks (confirmed by PoloBear) with ROM 5770 vanilla design card,  efi part from imac (Netkas Version), Bootscreen, Dualdisplay working, either DualDVI or DVI and Displayport, tested 2560x1600 and 1600x1200 in Pivot, Bootcamp not testedUnknown
CLUB-3D HD5770 (CGAX-5772I)
Radeon 5770, 1.0GB GDDR5, PCI-Express, Retail
UnknownUnknownUnknownUnknown


HIS 5870 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
HIS HD 5870 iCooler V  (H587FN1GDG)
1GB GDDR5 PCIe, 1.0GB GDDR5, PCI-Express
UnknownUnknownWorks with limitations (confirmed by boli) with ROM  5870 HIS or 587XZF18_uakari.rom, no video at boot until login screen, after that everything works fine - using two 24" displays at 1920x1200 on the DVI ports. Uakari rom seems to be a bit loud compared to HIS ROM.Probably works (same as on left)
HIS HD 5870 iCooler V (H587FN1GD)
1GB GDDR5 PCIe, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
HIS HD 5870 iCooler V Turbo (H587FNT1GD)
1GB GDDR5 PCIe, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
HIS HD 5870 iCooler V Turbo (H587FNT1GDG)
1GB GDDR5 PCIe, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown


HIS 5770 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
HIS HD 5770 Fan 1GB (128bit) (H577FL1GD)
GDDR5 PCIe, 1.0GB GDDR5, PCI-Express
Works with limitations with m57702.ROM confirmed by sunshine-x. Boot screen shows up when using a DVI->VGA adapter. Sunshine-x reports that he sometimes hears the "chime" sound during boot process.
Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)
HIS HD 5770 Fan (H577FM1GD)
1GB (128bit) GDDR5, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown
HIS HD 5770 IceQ Turbo 1GB (128bit) (H577QT1GD)
GDDR5, 1.0GB GDDR5, PCI-Express
UnknownUnknownUnknownUnknown


Diamond 5770 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
Diamond HD5770 (5770PE51G)
1GB DDR5-RAM, HDMI / 2x DVI / DisplayPort
Works with limitations with (ROM not yet known) confirmed by jenovadarkness. Not clear yet what works.
Probably works (same as on left)Probably works (same as on left)Probably works (same as on left)


VisionTek 5870 cardsMac Pro 1,1Mac Pro 2,1Mac Pro 3,1Mac Pro 4,1
VisionTek Radeon HD 5870  5870GHK
1GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFire Supported Video Card w/ATI Eyefinity
UnknownUnknownWorks with limitations with HIS5870.ROM confirmed by MachineShedFred. No boot screen, 24" Samsung DVI monitor fires up after loginwindow launch.  Stupidly fast framerates in Steam games.  Flashed using atiflash 3.79, had to use:  atiflash -fa -fm -fs -fp -p 0 his5870.rom Probably works (same as on left)
« Last Edit: October 11, 2010, 10:13:57 AM by lukenukem » Logged
jeanlain
Full Member
***
Offline Offline

Posts: 231


« Reply #1 on: September 06, 2010, 06:53:02 PM »

Nicely done.

(EDIT: I didn't see the data where just random examples).
Logged
lukenukem
Newbie

Offline Offline

Posts: 10


« Reply #2 on: September 06, 2010, 06:58:55 PM »

Well, if something like this doesn't exist yet. I will volunteer to start completing data with proper values :-)
Logged
numanumani
Newbie

Offline Offline

Posts: 1


« Reply #3 on: September 06, 2010, 09:00:54 PM »

HD-587X-ZNFV seems to work as well, on a MacPro 1,1. Sources:


nekonoko says he has the same card as robercik

robercik says he has a HD-587X-ZNFV

nekonoko reports success
Logged
jeanlain
Full Member
***
Offline Offline

Posts: 231


« Reply #4 on: September 06, 2010, 09:44:08 PM »

Add to this the XFX used by Macbidouille (same reference and same Mac Pro).
http://www.macbidouille.com/news/2010/09/01/maj-installer-une-radeon-hd5870-pc-dans-un-mac-pro-2006
(in French)
I believe its user "Aconu" on this forum:
http://forum.netkas.org/index.php/topic,334.msg2549.html#msg2549

Sapphire 5870 (don't know the precise model) working in Mac Pro 1.1 with custom ROM (but not with the XFX BIOS)
http://forum.netkas.org/index.php/topic,334.msg2608.html#msg2608

ATI technologies 5870: same thing (wrong fan behaviour with XFX_uakari BIOS)
http://forum.netkas.org/index.php/topic,334.msg2600.html#msg2600

Sapphire vaporX PN 288-1E140-200SA working with the XFX_uakari ROM on 1.1 Mac Pro
http://forum.macbidouille.com/index.php?showtopic=331736&view=findpost&p=3301412
(in French)


No problem reported apart the boot screen.

+ a variety of flashed 5870 and 5770 using the iMac's EFI on MacRumors' forum. I didn't follow this closely because it doesn't work on 1.1 Mac Pros. I think they have problem with triple-display (which appears to work fine using the EBC).
Logged
jeanlain
Full Member
***
Offline Offline

Posts: 231


« Reply #5 on: September 06, 2010, 09:47:43 PM »

Damn, my message is marked as spam because it contains too many links.  I have to start all over again. Angry

OK I give up. Can't post.
« Last Edit: September 06, 2010, 10:01:24 PM by jeanlain » Logged
jeanlain
Full Member
***
Offline Offline

Posts: 231


« Reply #6 on: September 06, 2010, 10:00:55 PM »

All using the EBC "Uakari" on 1.1 Mac Pros

XFX (same model as others) tested on Macbidouille (French),

Sapphire 5870 (don't know the precise model) with original BIOS+uakari EBC (not working properly with the XFX BIOS)

Same thing for an ATI technologies 5870 (XFX BIOS makes fan spin too fast--original BIOS is OK).

Sapphire vaporX PN 288-1E140-200SA working with the XFX BIOS. (in French)


+ a variety of flashed 5870s and 5770s using the iMac's EFI on MacRumors' forum. I didn't follow this closely because it doesn't work on 1.1 Mac Pros. I think they have problem with triple-display (which appears to work fine using the EBC).

ONE report of flashed sapphire 5770 with working boot screen but at crappy resolution, flashed with an EFI64-modified sapphire BIOS. (In French)
Logged
JadedGamer
Newbie

Offline Offline

Posts: 4


« Reply #7 on: September 07, 2010, 01:46:21 AM »

I have been following this forum for a few days now and I think I have read most topics regarding the 5770/5870 flashing stuff. However, what I'm missing a bit is some kind of an overview of what has been achieved already by netkas, rominator and the other great guys who have initiated all of this.

Is there some wiki page or some table that gives new users a quick overview of what already is possible with which configration (mac pro, graphic card, rom) and what has yet to be tested/hacked first?

If not, just to give you an example (with some example data) what I'm imagining:

CardMac Pro 1,1Mac Pro 1,2Mac Pro 1,3Mac Pro 1,4
Apple ATI Radeon 5770WorksWorksWorksWorks
Apple ATI Radeon 5870WorksWorksWorksWorks
Sapphire HD 5770  (11163-02-10/20)Partially works with ROM XY.
Only DVI port working
But no boot screen (link to post). Confirmed
Not testedNot testedWorks with ROM XY (link to post). Not confirmed yet.
Sapphire HD 5870  (11161-03-50)Partially works with ROM XY.
Only DVI port working
But no boot screen (link to post). Confirmed
Not testedNot testedWorks with ROM XY (link to post). Not confirmed yet.
Sapphire Vapor-X 5870 (11161-08-50R)Works with ROM XYNot testedNot testedNot tested
XFX Radeon HD 5870 (HD-587X-ZNFA)Works with ROM XYProbably won't work Not testedNot tested
XFX Radeon HD 5870 (HD-587A-ZNF9)Works with ROM XYProbably won't work (link to post)Doesn't work (link to post)Doesn't work (link to post)

lol...just jumped in and looked at the "overview", not noticing that it was all just example data.   Me being a Mac Pro 1,1 owner who has a Sapphire 5770, I saw that I only need find this Rom XY and I would be getting limited usage out of my card.   So I scoured the forum...damn no other mention of Rom XY.   Ok, maybe it's on another site...spent like 10 minutes googling to my hearts content.   Nothing....damnit.   Went back to the "overview" and read it all the way through.   Yeah...just example data...ok...I feel stupid now.
Logged
PoloBear
Newbie

Offline Offline

Posts: 6


« Reply #8 on: September 07, 2010, 07:08:36 AM »

Here is my Card:

Club3D HD5770 1Gb EAN CGAX-57724IDP
Ati Radeon 5770 Reference Design, black PCB, crappy loud Cooler, looks like Apple card, 2 DVI 1 HDMI 1DP

ROM:

5770 vanilla design card,  efi part from imac Netkas Version

MACPRO 3,1, Dual 2,8GHz Harpertown, early 2008:

Bootscreen, Dualdisplay working, either DualDVI or DVI and Displayport, tested 2560x1600 and 1600x1200 in Pivot
Card is less noisy than in PC with original ROM but louder than ATI 4870, Bootcamp not tested
« Last Edit: September 09, 2010, 12:04:58 AM by PoloBear » Logged
boli
Jr. Member
**
Offline Offline

Posts: 94



« Reply #9 on: September 07, 2010, 09:00:01 AM »

Mac & card:
I have a MacPro4,1 (early 2009, quad 2.93 GHz) and use a HIS Radeon HD 5870 with 1 GB memory (product code H587F1GDG). The card is in reference design, see this picture. Noise at idle is quite audible, way louder than the Apple 4870 I used to have - I ordered a new cooler to take care of it. Dunno about temps, Hardware Monitor doesn't support the card.

ROM:
I'm using the HIS5870.rom that Netkas made with the original ROM + EFI part from iMac, available at this post or list of evergreen Mac Pro ROMs.
No video at boot until login screen, after that everything works fine - using two 24" displays at 1920x1200 on the DVI ports.

P.S. Hi Luke!  Grin
« Last Edit: September 07, 2010, 07:43:09 PM by boli » Logged
PoloBear
Newbie

Offline Offline

Posts: 6


« Reply #10 on: September 07, 2010, 09:20:18 AM »

One more thing....
could everybody write something about cooler and noiselevel of the card and temps? Under OSX and windows if possible?
I bought the 5770 with first design (looks like the apple card), and compared to the my flashed 4870 it is cooler but really noisy.... when shopping for the 5870 i try to avoid this mistake. 
Logged
jeanlain
Full Member
***
Offline Offline

Posts: 231


« Reply #11 on: September 07, 2010, 09:53:16 AM »

Interesting, some 5770s have boot screen working. I don't think a single flashed 5870 shows video before drivers load. I'd like to be proven wrong though.

Regarding fan speed-- it could be the consequence of flashing with a BIOS that's not designed for the card. But making a custom BIOS is easy. See my post in the 5870 ROM thread. Plus, the ROM using EBC should work in all Mac Pros (but it's designed for 5870s only). The method should work with EFI-modified ROMs too, with minor changes.
Logged
lukenukem
Newbie

Offline Offline

Posts: 10


« Reply #12 on: September 07, 2010, 11:33:41 AM »

Club 3D HD5770
Ati Radeon 5770 Reference Design, black PCB, crappy loud Cooler, looks like Apple card, 2 DVI 1 HDMI 1DP

Thanks :-) Do you know by chance the product code of your card?
(CGAX-57724DPO, OC Edition, DDR5 speed 1.233GHz) or (CGAX-57724IDP, DDR5 speed 1.2 GHz)
Logged
PoloBear
Newbie

Offline Offline

Posts: 6


« Reply #13 on: September 07, 2010, 01:03:33 PM »

This is my Card:
Club3D HD5770 EAN CGAX-57724IDP
Logged
abccba
Newbie

Offline Offline

Posts: 2


« Reply #14 on: September 08, 2010, 07:26:56 AM »

I have both this: http://www.ncix.com/products/index.php?sku=44932&vpn=HD577AZNFC&manufacture=XFX
and this: http://www.ncix.com/products/index.php?sku=48511&vpn=HD577AZNDC&manufacture=XFX

working beautifully in my 3,1 Mac Pro. No EFI boot screen though...

(both were flashed with the saphire vanilla rom)

cheers!
Logged
Pages: [1] 2 3 ... 8
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!