netkas.org forum
January 18, 2017, 05:09:36 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 ... 62
  Print  
Author Topic: 6970 reports  (Read 334449 times)
andystubbs
Hero Member
*****
Offline Offline

Posts: 505



« Reply #15 on: September 06, 2011, 06:41:21 AM »

Here is patched binary of kext.

http://rghost.ru/20594481

disables uvd on anything from 6xxx

Thanks very much netkas, much appreciated.

Updated packages including netkas' latest fix for iTunes..

Standard Package (Without ATY_Init)  = http://www.mediafire.com/?4wxtlw6ftuaua35

Native package (With ATY_Init) = http://www.mediafire.com/?9m966bmwe9ib9sw

Both will install Netkas' fix and the latest ATi drivers - the ONLY difference is the ATY_Init.kext.

On a hackintosh you can use either package provided you have compiled chameleon with 6970 support and use graphicsenabler, if you dont have support in chameleon for 6970 or do not use graphicsenabler then you need to use the native package, if you do have support in chameleon and do use graphicsenabler then use the standard package.

On a genuine Mac you need to follow Netkas' advice so use the Standard package and NOT the Native one.

« Last Edit: September 06, 2011, 07:21:39 AM by andystubbs » Logged
Peloche
Jr. Member
**
Offline Offline

Posts: 85


« Reply #16 on: September 06, 2011, 08:07:30 AM »

Here is patched binary of kext.

http://rghost.ru/20594481

disables uvd on anything from 6xxx

Works well Netkas, you aren't good, you're Very Good  Cheesy

Thanks and congrats
Logged

CoolerMaster HAF932
PS Enermax MODU87+ 600W
ASUS SABERTOOTH X58
i7 930,2,8 GHz;Noctua NH-U12P SE2
DDR3 6 x 2 Go PC3-10666 CAS 7 XMS 3 Corsair
SSD 64 GB C300 Crucial CTFDDAC064MAG
WD1500ADFS;HDT722525DLA380;ST3500630AS
Seagate Momentus XT 750 Go
NVidia GTX670 2Gb
10.8.-WIN8-64
chadsky
Newbie

Offline Offline

Posts: 12


« Reply #17 on: September 06, 2011, 12:06:09 PM »

Уважаемый Неткас ! Правильно ли я понимаю, что на маке про 1,2 (в девичестве 1,1) картинку при загрузке мы все равно не увидим по причине его 32битного EFI вне зависимости от версии и названия карты ?
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 793



« Reply #18 on: September 06, 2011, 01:08:52 PM »

yep

I even can make ebc efi rom for it based on 5870's rom, but it will not bring boot screen anyway.
Logged
killercheung
Newbie

Offline Offline

Posts: 2


« Reply #19 on: September 06, 2011, 11:04:40 PM »

Thanks netkas
It works great on my gigabyte 6950 2GB with 6970 mod bios (and the itunes fix works too!!!)
Finally I can have a DX11 card on my hackintosh  Cool
Logged
Cindori
Full Member
***
Offline Offline

Posts: 237



WWW
« Reply #20 on: September 07, 2011, 04:53:04 PM »

Cindori goes Cindori Custom 2.0:









Courtesy of netkas!

click on images to get larger view.

any1 up for some Battlefield 3??

« Last Edit: September 07, 2011, 04:55:20 PM by Cindori » Logged

http://groths.org
Tools and news about Mac graphics and Hackintosh
Rominator
Hero Member
*****
Offline Offline

Posts: 2074



« Reply #21 on: September 07, 2011, 07:25:18 PM »

every time I step out of town for a couple days there is some big breakthrough !!!

Guess I need to order a 6970 and get ready to join the fun on my return

Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
andystubbs
Hero Member
*****
Offline Offline

Posts: 505



« Reply #22 on: September 07, 2011, 07:54:25 PM »

Cindori goes Cindori Custom 2.0:



Thats a very clean build you have there - I must tidy up my cabling one day!
Logged
andystubbs
Hero Member
*****
Offline Offline

Posts: 505



« Reply #23 on: September 07, 2011, 07:59:37 PM »

Just for info - I've not had a single grey or white screen freeze during boot on my hack as yet - is it possible this only affects macs?
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 793



« Reply #24 on: September 07, 2011, 08:01:47 PM »

no affects pcs as well, but only on cold start.

and If I boot windows first then osx, works fine.
Logged
andystubbs
Hero Member
*****
Offline Offline

Posts: 505



« Reply #25 on: September 07, 2011, 09:55:13 PM »

I'll try that tomorrow - I will cold boot straight into Lion but assuming it happens then it sounds like it could be a powerplay quirk (i.e gpu clockspeed screwing up with the drivers).
Logged
afd_sg
Newbie

Offline Offline

Posts: 6



« Reply #26 on: September 08, 2011, 12:58:37 AM »

Thanks again to Netkas et all.

I am using PowerColor 6950 with 2GB ram,  card is un-modded with the bios switch on the card set to position one. MB is an ASUS Sabertooth X58 with 12 GB of memory, and running osx 10.7.1 with Andy's Native package loaded without probs. I am not using GE as the version of Chameleon does not support the card and I have not been successful with modding ati.c.

I am not a gamer and the only issue I have is the cold start grey screen without mouse pointer and a reset fixes that,  and I would also confirm that if I boot into Windows 7, then restart in OSX Lion there is no prob.

As mentioned on the front page, sleep is a problem as it will sleep but it wakes up with a frozen screen requiring a hard reset, which is a pity. My former 5770 worked fine with sleep and wake and it was very reliable as it was unnecessary to power down the computer at all.

With the 6950 sleep/wake would be the icing on "the cake".
« Last Edit: September 08, 2011, 02:34:35 AM by afd_sg » Logged

Chameleon-22.1svn-r1508
MB:Asus Sabertooth X58
CPU:Intel i7-960
GPU:Powercolor - HD 6950 2GB (unmodded)
RAM:12GB 3x4 Corsair CMX12GX3M3A2000C9
HDD:2X1TB 1X640GB 1xSSD 32GB
plans
Newbie

Offline Offline

Posts: 26


« Reply #27 on: September 08, 2011, 01:46:12 AM »

I suppose it's safe to say there is very little chance 6970 will ever work on Snow Leopard?

Regardless, incredible work by netkas and crew. Nice job Smiley
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 793



« Reply #28 on: September 08, 2011, 12:54:20 PM »

Just to tell you why it's not gonna work in SnowLeopard

in order to get working framebuffer in SL we had to use Lion's X3000.kext.

now the problem, that X3000.kext isn't compatible with SL's X3000GLDriver.bundle.

and Lion's X3000GLDriver.bundle isn't compatible with SL's OpenGL.framework

so, no go, max I can get is this glview record

<Vendor>ATI Technologies Inc.</Vendor>
<Version>2.1 ATI-1.6.36</Version>
<GLSLVersion>1.20</GLSLVersion>
<Renderer>ATI Radeon CNIA Prototype OpenGL Engine</Renderer>
<Extensions>GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_vertex_blend GL_ARB_window_pos GL_ARB_shader_objects GL_ARB_vertex_shader GL_ARB_shading_language_100 GL_EXT_multi_draw_arrays GL_EXT_clip_volume_hint GL_EXT_rescale_normal GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_geometry_shader4 GL_EXT_transform_feedback GL_APPLE_client_storage GL_APPLE_specular_vector GL_APPLE_transform_hint GL_APPLE_packed_pixels GL_APPLE_fence GL_APPLE_vertex_array_object GL_APPLE_vertex_program_evaluators GL_APPLE_element_array GL_APPLE_flush_render GL_APPLE_aux_depth_stencil GL_NV_texgen_reflection GL_NV_light_max_exponent GL_IBM_rasterpos_clip GL_SGIS_generate_mipmap GL_ARB_imaging GL_ARB_point_parameters GL_ARB_texture_env_crossbar GL_ARB_texture_border_clamp GL_ARB_multitexture GL_ARB_texture_env_add GL_ARB_texture_cube_map GL_ARB_texture_env_dot3 GL_ARB_multisample GL_ARB_texture_env_combine GL_ARB_texture_compression GL_ARB_texture_mirrored_repeat GL_ARB_shadow GL_ARB_depth_texture GL_ARB_shadow_ambient GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_occlusion_query GL_ARB_point_sprite GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ARB_pixel_buffer_object GL_ARB_draw_buffers GL_ARB_shader_texture_lod GL_ARB_color_buffer_float GL_ARB_half_float_vertex GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_ARB_framebuffer_object GL_EXT_compiled_vertex_array GL_EXT_draw_buffers2 GL_EXT_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_texture_rectangle GL_ARB_texture_rectangle GL_EXT_texture_env_add GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_lod_bias GL_EXT_abgr GL_EXT_bgra GL_EXT_stencil_wrap GL_EXT_texture_filter_anisotropic GL_EXT_separate_specular_color GL_EXT_secondary_color GL_EXT_blend_func_separate GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_texture_compression_s3tc GL_EXT_texture_compression_dxt1 GL_EXT_texture_sRGB GL_EXT_blend_equation_separate GL_EXT_texture_mirror_clamp GL_EXT_packed_depth_stencil GL_EXT_bindable_uniform GL_EXT_texture_integer GL_EXT_gpu_shader4 GL_EXT_framebuffer_sRGB GL_EXT_provoking_vertex GL_APPLE_flush_buffer_range GL_APPLE_ycbcr_422 GL_APPLE_rgb_422 GL_APPLE_vertex_array_range GL_APPLE_texture_range GL_APPLE_float_pixels GL_ATI_texture_float GL_ARB_texture_float GL_ARB_half_float_pixel GL_APPLE_pixel_buffer GL_APPLE_object_purgeable GL_NV_blend_square GL_NV_fog_distance GL_NV_conditional_render GL_ATI_texture_mirror_once GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_texture_env_combine3 GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGI_color_matrix GL_EXT_texture_array GL_EXT_vertex_array_bgra GL_ARB_instanced_arrays GL_ARB_depth_buffer_float GL_EXT_packed_float GL_EXT_texture_shared_exponent </Extensions>
<VRAM>2047</VRAM><Capabilities>

trying to init 3d context results in app crash.
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 793



« Reply #29 on: September 08, 2011, 01:20:34 PM »

And about outputs on 6970

seems to be same as 6870's, except:
1) second DVI works for dvi displays (vga isnt supported on that port by design)
2) hdmi display doesnt work on dvi ports with dvi->hdmi adapter.
Logged
Pages: 1 [2] 3 4 ... 62
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!