netkas.org forum
April 25, 2017, 11:38:59 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1] 2 3 ... 30
  Print  
Author Topic: 6870 efi rom test  (Read 281037 times)
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 799



« on: August 14, 2011, 10:36:37 AM »

If anybody has 6870 card and macpro with 64-bit efi and is able to flash ati card, post in this thread.

Latest roms.
Instructions.

GUI to dump&create rom - http://forum.netkas.org/index.php/topic,1085.msg6648.html#msg6648
« Last Edit: August 26, 2011, 01:18:04 PM by netkas » Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #1 on: August 17, 2011, 02:08:16 PM »

I have a 2009 mac pro (64bit EFI) with a 6870 that I'm just about to install when I get home later today.

I put together and flashed my own 4870 ROM (using cindori's mac flasher) two years ago so I'm familiar with the procedure.
« Last Edit: August 17, 2011, 02:11:40 PM by Dakoman » Logged
harrinp1
Newbie

Offline Offline

Posts: 4


« Reply #2 on: August 17, 2011, 02:31:47 PM »

I've got a MacPro 3,1 running 10.7.1 and have a 6870.
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 799



« Reply #3 on: August 18, 2011, 05:14:28 AM »

dump your video bios with gpu-z and post here, I'll make efi.rom.
Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #4 on: August 18, 2011, 07:51:05 AM »

Here you go I actually had some trouble dumping it as my screen went black and the entire computer went unresponsive during the dump, but I waited 10 minutes and rebooted and sure enough the bios image was where I asked GPU-Z to save it so it was probably just a windows/driver issue.

I'm not using a reference card btw, but a HIS IceQ X which has a slight factory overclock (not that I care about keeping it).

Will I be OK to use winFlash to flash?

* dakoman6870.bin (128 KB - downloaded 167 times.)
« Last Edit: August 18, 2011, 08:25:59 AM by Dakoman » Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 799



« Reply #5 on: August 18, 2011, 10:44:24 AM »

Here it is.

Just make sure You have a way to flash it back to original rom (a PC for example) cuz we dunno how it will go (well, flashed card should work in pc at least).
« Last Edit: August 19, 2011, 12:35:58 AM by netkas » Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #6 on: August 18, 2011, 01:49:51 PM »

I don't actually have a PC at hand at the moment, do you think that if it doesn't work it would prevent the computer from booting at all? Because I have VNC running so I can always use that to reflash.
Logged
netkas
Administrator
Hero Member
*****
Offline Offline

Posts: 799



« Reply #7 on: August 18, 2011, 02:49:38 PM »

computer should boot, maybe no screen, better enable ssh (remote login).

In worst case second (efi) card should help
Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #8 on: August 18, 2011, 03:47:38 PM »

Thanks a lot! I'll be home in 4 hours and I'll let you know how it goes, although I only have the means to test the DVI ports (I don't have a MDP display or a VGA display). I'm guessing what we're really looking for here though is the boot screen Smiley I always have SSH running, but I'll enable a VNC server in windows as well; cindori's Zeus tool won't flash the 6870 (I tried doing it remotely from work Tongue)
« Last Edit: August 18, 2011, 03:49:20 PM by Dakoman » Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #9 on: August 18, 2011, 09:19:07 PM »

It worked! Flashed using winflash on windows, get the EFI boot screen and Lion 10.7.1 reports a ATI Radeon HD 6xxx with EFI Driver version 01.00.507.

However, geekbench/steam games/dvdplayer crash on launch, so it's not a perfect solution.
Logged
harrinp1
Newbie

Offline Offline

Posts: 4


« Reply #10 on: August 18, 2011, 09:22:39 PM »

It worked! Flashed using winflash on windows, get the EFI boot screen and Lion 10.7.1 reports a ATI Radeon HD 6xxx with EFI Driver version 01.00.507.

However, geekbench/steam games/dvdplayer crash on launch, so it's not a perfect solution.

So do I need to install bootcamp/windows in order to download and flash the GPU?  Does bootcamp work okay without the efi bootscreen?

Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #11 on: August 18, 2011, 09:24:54 PM »

I used flipside to boot into windows once without the need for the EFI boot screen
Logged
dingles
Newbie

Offline Offline

Posts: 3


« Reply #12 on: August 18, 2011, 09:25:29 PM »

I have an XFX HD6870 and a Mac Pro 3,1. I was using a flashed 5770 prior to this so I know the drill. I can post my ROM in a couple of hours if you're still interested.
Logged
Dakoman
Newbie

Offline Offline

Posts: 23


« Reply #13 on: August 18, 2011, 09:40:37 PM »

Ok so the interesting thing is that with the ATY_Init from here: http://www.groths.org/?p=297

The original BIOS works fine in steam/dvd player/GB, but with the EFI BIOS it still crashed..

I'm going to stick with the original BIOS until this gets ironed out as being able to use steam games in Mac is more important than having an EFI boot screen at the moment (I can get to bootcamp through software). If there's anything you think I should try then let me know (I tried using the newest ATY_Init on netkas.org but it made my mac pro unbootable with the card installed so I booted it headless and removed the kext via SSH).
Logged
Rominator
Hero Member
*****
Offline Offline

Posts: 2101



« Reply #14 on: August 18, 2011, 10:04:07 PM »

I have tried EFI 6870 from an EFI Netkas sent me.

Didn't work on EFI32 Mac Pro 1,1

Keep in mind that card still "works" just no boot screens from EFI.
« Last Edit: August 19, 2011, 09:52:39 PM by Rominator » Logged

Before asking a question, check your "Personal Settings" and be sure that you have "Brain Services" set to "On".
Pages: [1] 2 3 ... 30
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!